Working with MacPorts on MacBook Pro (Intel) and rsync problems.

Ryan Schmidt ryandesign at
Tue Jun 26 11:30:20 PDT 2007

On Jun 26, 2007, at 10:40, Frederick C. Lee wrote:

> My Environment: MacBook Pro (Intel).
>                              OS X (Tiger) v10.4.10
> Original intent: to install Ruby & ancillary files.
> I have a few questions...
> 1) Do I need to inform MacPorts which version of code is requested  
> (intel vs PPC)?

No, you don't need to tell it. On PowerPC, it will build PowerPC  
code. On Intel, it will build Intel code.

> Example:  I'm trying to install 'readline', that is required to  
> install Ruby.
> Looking at the variants, I see two (2).  I believe I need the  
> 'universal' variant.
> [Users/Ric] > variants readline
> readline has the variants:
>         universal
>         darwin
> ... do I have to explicitly request the 'universal'?  How?

You only need "universal" if you plan to use your install ports on  
both Intel and PowerPC Macs, for example if you are installing  
MacPorts onto an external hard disk that you plan to move between  
machines. This would be unusual. For the usual usage of installing  
MacPorts onto and using it on only one Mac, you do not need "universal".

> So, to install Ruby, I need readline.  To install readline, I need  
> to rsync.
> 2) I tried to import/install 'readline' and failed:
> [/Users/Ric]sudo port install readline-5
> --->  Installing readline-5 5.0.005_0+darwin_8
> --->  Activating readline-5 5.0.005_0+darwin_8
> Error: Target returned: Image error: /opt/local/ 
> lib/libhistory.5.0.dylib already exists and does not belong to a  
> registered port.  Unable to activate port readline-5.
> Error: Status 1 encountered during processing.

MacPorts handles dependencies for you. If ruby requires readline,  
asking MacPorts to install ruby will cause it to install readline.

In particular, the ruby port depends on the readline port, not the  
readline-5 port. I don't know why it says that /opt/local/lib/ 
libhistory.5.0.dylib does not belong to a registered port. On my  
system, it is provided by the readline port:

$ port provides /opt/local/lib/libhistory.5.0.dylib
/opt/local/lib/libhistory.5.0.dylib is provided by: readline

So I would say: stop trying to install readline-5 and just install  
ruby, or whatever else you want to install, and MacPorts should take  
care of the rest.

> 3) I also need rsync to work:
> [Users/Ric] > selfupdate
> Error: /opt/local/bin/port: selfupdate failed: Couldn't sync dports  
> tree: sync failed doing rsync
> Looking at the rsync:
> [/Users/Ric]rsync --version
> rsync  version 2.6.9  protocol version 29
> Copyright (C) 1996-2006 by Andrew Tridgell, Wayne Davison, and others.
> <>
> Capabilities: 64-bit files, socketpairs, hard links, symlinks,  
> batchfiles,
>               inplace, IPv6, 32-bit system inums, 64-bit internal  
> inums
> BTW: I'm not too sure if v2.6.9 is working correctly.  I have the  
> original v2.6.3(OS X) but get the same result.

As far as I know, either the Mac OS X version or the MacPorts version  
of rsync should work fine for selfupdate and sync. I don't know why  
your rsync failed here.

More information about the macports-users mailing list