error on port selfupdate

Marco Battistella macports.mb at
Wed Mar 7 15:48:48 PST 2007

when trying to run a port selfupdate command i get the following error:

sudo port selfupdate
DarwinPorts base version 1.310 installed
Downloaded DarwinPorts base version 1.320
Configuring, Building and Installing new DarwinPorts base
Error: /opt/local/bin/port: selfupdate failed: Error installing new  
DarwinPorts base: shell command "cd /opt/local/var/db/dports/sources/ 
rsync.rsync.darwinports.org_dpupdate1/base && ./configure --prefix=/ 
opt/local --with-install-user=root --with-install-group=admin --with- 
tclpackage=/Library/Tcl && make && make install" returned error 77
Command output: checking build system type... powerpc-apple-darwin7.9.0
checking host system type... powerpc-apple-darwin7.9.0
checking target system type... powerpc-apple-darwin7.9.0
checking for gcc... gcc
checking for C compiler default output file name... configure: error:  
C compiler cannot create executables
See `config.log' for more details.

I have found a thread from this mailing list describing the same  
error but it ends without a solution.

This is in a system with a fresh OS install, my configuration is OS X  
server 10.3.9 with xTools installed and all updates installed.
I tried re installing darwingports but i still get the same error.
any help will be appreciated.

More information about the macports-users mailing list