error on port selfupdate [solved ?]

Marco Battistella macports.mb at
Wed Mar 14 07:26:57 PDT 2007

not finding any other way to fix the problem i decided to start from  
scratch, i reformatted the drive and made a new fresh installation of  
the OS and then of darwinPorts.
When the time came to install xtools I noticed that had a few  
different discs, in particular one labeled as xtools 1.0 and another  
as xtools 1.2 (coming form different sets of OS X). During my  
previous install i must have used the 1.0 disc as I remember it  
downloading the 1.1 update form software updates but it never  
(explicitly) updated to 1.2.
Could this be the issue I was having?
Unfortunately i was not able to find anything about this in the apple  
developer website.
I someone else encounter the same problem that might be something to  
look into.
take care,

On Mar 7, 2007, at 10:42 PM, Marco Battistella wrote:

> HI,
> actually that was the first thing I had tried (thinking that I  
> might had forgot to install the xtools).
> Anyway i ran the xtools installer it again, just to try, but the  
> error persists.
> Does anybody know where the config.log for this operation is located?
> thanks,
> Marco
> On Mar 7, 2007, at 7:04 PM, Christian Voelker wrote:
>> Hello,
>> Am 08.03.2007 um 00:48 schrieb Marco Battistella:
>>> when trying to run a port selfupdate command i get the following  
>>> error:
>>>>>> checking for C compiler default output file name... configure:  
>>> error: C compiler cannot create executables
>>> See `config.log' for more details.
>>> This is in a system with a fresh OS install, my configuration is  
>>> OS X server 10.3.9 with xTools installed and all updates installed.
>>> I tried re installing darwingports but i still get the same error.
>> I would try and install Developer Tools again. I had exactly the  
>> same error
>> on a completely different machine (iMac G5, Mac OS X 10.4.8 and  
>> Developer
>> Tools 2.4.0). I believe that somebody (myself?) did a partial  
>> install of
>> Developer Tools before. I just installed Developer Tools 2.4.1  
>> over it
>> and everything went fine afterwards.
>> Bye, Christian
> _______________________________________________
> macports-users mailing list
> macports-users at

More information about the macports-users mailing list