jpeg (?) troubles (flphoto, eog)

Randall Wood rhwood at
Sat Mar 17 11:30:47 PDT 2007

eog dies on some freetype problem that I have not been able to  
reproduce anywhere else.

What does gthumb do?

On 17 Mar 2007, at 11:57, Stefan Bruda wrote:

> Hi,
> I am having what I believe to be problems with the jpeg package.  They
> manifest themselves most notably in FLTK applications (only one realy,
> flPhoto) but I also believe that they are the cause of eog crashes.
> It goes like this: fltk builds fine as is, but fluid crashes upon
> startup and so does flphoto (probably other fltk applications too, but
> I have not tried anything else).  I then built fltk with
> --disable-shared and I thus get both fluid and flphoto to run.
> flphoto however dies with
>    JPEG parameter struct mismatch: library thinks size is 356, caller
>    expects 372
> the moment it tries to write a JPEG image (reading seems fine).
> Reading EXIF data from JPEG photos results in bus errors (are these
> the segfaults of BSD, bu the way?).
> Googling this resulted in the most encountered conclusion that the
> jpeg headers and binaries come from two different versions, or that
> integer size or allignment are different from one binary to another.
> I tried playing around with -malign-double (in both fltk and flphoto).
> The mismatch values change (library thinks size is 360, caller expects
> 376) but they are off by the same amount.  I thus conclude that the
> first cause (mismatching between headers and binaries in the jpeg
> package) are the culprit.  Problem is, I am not aware of any duplicate
> installation.  Actually I have only two jpeglib.h, one from MacPorts
> and another from a Gentoo prefixed installation (whose paths are I
> believe not included anywhere).  Same goes for libjpeg.dylib.
> In possibly incidental matter, eog crashes upon startup, I have no
> idea how to dig for the cause (is there any way to build programs with
> debugging on short of hacking each and every port?).  It might be
> unrelated, but I would really appreciate any hint about this how
> unrelated this might be.
> Interestingly enough the Gimp runs just fine...
> For the moment I hacked flphoto and I replaced all its attempts to
> write JPEGS with calls to Imagemagick utilities (they work fine too),
> and I simply suppressed everything that deals with EXIF data.  In all,
> I am reasonably happy as far as flphoto is concerned.  However, I miss
> eog and I would generaly take a good solution instead of my hack at
> any time of day.
> I am running Mac OS 10.4.9 (all of this happened in 10.4.8 too) and
> MacPOrts 1.32 on a Core 2 Duo Macbook Pro.  I am good at hacking but I
> am just beginning to get hold of MacPorts (I come however from Gentoo
> Linux so I am reasonably comfortable with the idea).  So any advice,
> however technical, is appreciated.  I am not sure what other
> information to include so please ask for anything that I missed here.
> Thanks in advance,
> Stefan
> -- 
> If it was so, it might be; and if it were so, it would be; but as
> it isn't, it ain't.  That's logic.
>     --Lewis Carroll, Through the Looking-Glass
> _______________________________________________
> macports-users mailing list
> macports-users at

Randall Wood
rhwood at

"The rules are simple: The ball is round. The game lasts 90 minutes.  
All the
rest is just philosophy."

More information about the macports-users mailing list