Newbie ncursesw problem - can't install apache2

Baron Fujimoto at
Mon Mar 19 13:35:22 PDT 2007

On Fri, 16 Mar 2007, John Korchok wrote:

: I am trying to install apache2 on an Intel Mac, but when it tries to build
: ncursesw I always get:
: ---> Building ncursesw with target all
: Error: Target returned: shell command "cd
: "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync
: darwinports.org_dpupdate_dports_devel_ncursesw/work/ncurses-5.5" && make
: all" returned error 2
: Command output: cd man && make DESTDIR="" all
: make[1]: Nothing to be done for `all'.
: cd include && make DESTDIR="" all
: make[1]: Nothing to be done for `all'.
: cd ncurses && make DESTDIR="" all
: gawk -f ./tinfo/MKnames.awk ./../include/Caps
: make[1]: *** [codes.c] Illegal instruction
: make: *** [all] Error 2
: Error: The following dependencies failed to build: ncursesw
: Error: Status 1 encountered during processing.
: I've tried all the usual clean -all installed and finally uninstalled
: everything to start over, but I'm still getting this report. Any ideas?

I am also having the problems with any port (or its dependencies) that
require ncursesw (e.g. mutt, svn, etc).  I'm not sure if my problems are
related to your's, but it's at least coincidental that they both involve

% mutt
  dyld: Library not loaded:
    Referenced from: /opt/local/bin/mutt
    Reason: image not found
  Trace/BPT trap

I've tried uninstalling, cleaning and rebuilding the port and its dependencies, but always with the same results.

More information about the macports-users mailing list