Problems with libgda-1.2.4

Frank McPherson frank.mcpherson at
Tue Mar 20 08:13:21 PDT 2007

I'm having trouble building this port. It's in my dependency path as  
I try to install gtk-sharp. I'm running 10.4.9 and the latest dev  
tools. I'm on ports 1.320 and have a mostly-up-to-date set of ports  
installed, including the lastest mysql5.

I try to build libgda with "sudo port install libgda" I get the  
--->  Extracting libgda
Error: Target returned: could not create new link "/ 
orts_gnome_libgda/work/pgsql/include" since target "/opt/local/ 
include/pgsql8" doesn't exist
Error: Status 1 encountered during processing.

Fair enough, I'll just install postgresql80, which appears to be the  
specific port version required by libgda, even though I don't use  
postgresql80. I tried specifying only +mysql, but got the same error.

Now I get
... (let me know if you want to see all the successful build commands)
gcc -dynamiclib ${wl}-undefined ${wl}dynamic_lookup -o .libs/ 
libgdasql.3.0.0.dylib  .libs/parser.o .libs/lexer.o .libs/ 
sql_parser.o .libs/mem.o .libs/sql_display.o .libs/sql_tree.o  -L/opt/ 
local/lib -L/opt/local/var/db/dports/build/ 
orts_gnome_libgda/work/pgsql/lib /opt/local/lib/libgobject-2.0.dylib / 
opt/local/lib/libgthread-2.0.dylib /opt/local/lib/ 
libgmodule-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/ 
libintl.dylib /opt/local/lib/libxslt.dylib /opt/local/lib/libz.dylib / 
opt/local/lib/libxml2.dylib -lpthread -lz /opt/local/lib/ 
libiconv.dylib -lm  -Wl,-undefined -Wl,dynamic_lookup -install_name  / 
opt/local/lib/libgdasql.3.dylib -Wl,-compatibility_version -Wl,4 -Wl,- 
current_version -Wl,4.0
ld: warning -L: directory name (/opt/local/var/db/dports/build/ 
orts_gnome_libgda/work/pgsql/lib) does not exist
ld: flag: -undefined dynamic_lookup can't be used with  
MACOSX_DEPLOYMENT_TARGET environment variable set to: 10.1
/usr/bin/libtool: internal link edit command failed
make[1]: *** [] Error 1
make: *** [all-recursive] Error 1

Error: Status 1 encountered during processing.

What's this about a 10.1 deployment target? I'm stumped.

Thanks in advance for any help,

More information about the macports-users mailing list