Smultron 3.2 portfile error

Ryan Schmidt ryandesign at
Sun Nov 4 12:28:46 PST 2007

On Nov 4, 2007, at 05:23, William Davis wrote:

> Smultron 3.2 refused to upgrade from 3.1.x with message about 3.2  
> only working on Leopard systems. Unfortunatly I have a Leopard system.
> When I removed || (variant_isset darwin_8) from the if ...then test  
> expression line then Smultron @3.2 installed with no problem.   
> according to the -d output Smultron @3.2 furnishes darwin_8 and  
> darwin_9.
> I have cc'd the maintainer on this, but I havnt made a ticket  
> because I have no idea if this is the "proper" way to fix the problem.
> To be clearer
> --    if {[variant_isset darwin_6] || [variant_isset darwin_7] ||  
> [variant_isset darwin_8]} {
> ++   if {[variant_isset darwin_6] || [variant_isset darwin_7] } {
> --        if {$xcodeversion  == "2.1"} {
> ++       if {$xcodeversion == "3.0"} {
> this does let Smultron 3.2 build and run under os 10.5
> William Davis
> frstanATbellsouthDOTnet
> Mac OS X.5.0 Darwin 9.0.0
> Mac Mini Intel Duo @ 1.86 GHz

That can't be right. Mac OS X 10.5 is Darwin 9, as you say, so  
removing the darwin_8 variant section from the portfile cannot be the  
correct solution.

If I had to guess, I'd say perhaps you did this?

1. You installed Smultron 3.1.2 while on Tiger; this installed  
smultron 3.1.2_0+darwin_8
2. You upgraded to Leopard.
3. You tried to upgrade to Smultron 3.2. Because you had previously  
(auto-)selected the darwin_8 variant, port tried to select it again,  
even though it is now inappropriate for your new OS.

If this is the case, then the solution is not to modify the portfile  
in any way, but to (forcibly?) uninstall any port you have installed  
that has the +darwin_8 variant, and reinstall it so that it gets (if  
applicable) the +darwin_9 variant.

More information about the macports-users mailing list