Image Error: redland-bindings does not exist

Ryan Schmidt ryandesign at
Sat Nov 10 11:49:18 PST 2007

On Nov 9, 2007, at 04:21, Ryan Schmidt wrote:

> On Nov 8, 2007, at 09:25, Christoph Ambichl wrote:
>> I want to install Redland RDF Language bindings for perl (http:// 
>> in Leopard, but I get this  
>> error message:
>> Macintosh:~ chri$ sudo port install redland-bindings
>> --->  Activating redland-bindings
>> Error: Target org.macports.activate returned: Image error: Source  
>> file /opt/local/var/macports/software/redland-bindings/  
>> does not appear to exist (cannot lstat it).  Unable to activate  
>> port redland-bindings.
>> Error: Status 1 encountered during processing.
>> I am new to Mac, so I have no idea where to locate the error.
>> I successfully installed other packages like p5-xml-writer or p5- 
>> yaml.
>> I have a MacBook with Intel CPU, and OS X Leopard (upgraded from  
>> 10.4).
>> I use XCode 3.0, MacPorts 1.520 and the package I want to install is:
>> redland-bindings               www/redland-bindings       
>> Redland RDF Language Bindings
> Just wanted to quickly say that I get the same error on Tiger with  
> Xcode 2.4.1 on Intel. Please file a bug in Trac and Cc it to the  
> port's maintainer.

You know, I just tried

sudo port install redland-bindings +php

and it worked. So maybe you just need to tell it what bindings you  
want. See the available bindings by running

port variants redland-bindings

If that works, great, but you should still file a bug in Trac so that  
the port can be fixed. (It should print a message advising users that  
they must select at least one variant; it shouldn't just fail with a  
cryptic error as it currently does.)

More information about the macports-users mailing list