Error installing xfig -- directory not emty

Ryan Schmidt ryandesign at
Fri Nov 16 02:04:14 PST 2007

On Nov 15, 2007, at 20:49, Charles Rich wrote:

> On Nov 14, 2007, at 4:31 PM, William Davis wrote:
>> On Nov 14, 2007, at 2:01 PM, Charles Rich wrote:
>>> Here's the error:
>>> sudo port upgrade xfig
>>> --->  Fetching xfig
>>> --->  Verifying checksum(s) for xfig
>>> --->  Extracting xfig
>>> --->  Applying patches to xfig
>>> --->  Configuring xfig
>>> --->  Building xfig with target all
>>> --->  Staging xfig into destroot
>>> Error: Target org.macports.destroot returned: error deleting "/ 
>>> opt/local/var/macports/build/ 
>>> _opt_local_var_macports_sources_rsync.macports.org_release_ports_gra 
>>> phics_xfig/work/destroot/usr/X11R6/lib/X11/app-defaults":  
>>> directory not empty
>>> The directory has two files:  Fig and Fig-color
>>> I tried redoing this multiple times and variations (with -f,  
>>> etc.), but to no avail.
>> sudo port -d clean xfig
>> then try upgrading again.
> Cleaning and reinstalling was one of the first variations I tried.   
> No difference in behavior.  I think it is must be a bug in the  
> install script for xfig?

xfig installs fine for me. But I believe I encountered this problem  
too, back when I had the XFree86 port installed. IIRC uninstalling  
XFree86 and using Apple's X11 instead was the workaround.

But it would be nice if the port would work with both environments,  
and you should file a bug about this in Trac. Be sure to assign it to  
the port's maintainer. Instructions on filing bugs are here:

More information about the macports-users mailing list