selfupdate failing under Leopard (yes I read the other posts about this)

Daniel J. Luke dluke at
Fri Nov 16 06:52:38 PST 2007

On Nov 16, 2007, at 9:11 AM, Stuart Tannehill wrote:
> OK, MacPorts is working fine. I can add ports, upgrade them, etc. I  
> cannot,
> however, run selfupdate. The latest Xcode is installed, X11 is as  
> well. No
> ports are being blocked.
> I ran the install commands manually. Configure completes  
> successfully but
> Make fails with the following error: "ld: warning in
> /usr/local/lib/libreadline.dylib, file is not of required  
> architecture"
> So I used MacPorts to update the copy of libreadline.dylib in /opt  
> to the
> latest version, copied it over to /usr/local/lib and then ran  
> selfupdate
> again. It worked properly. I did switch back to the original version  
> of
> libreadline.dylib because I don't want to screw up anything Apple  
> has going
> on with it. Ya never know.

Apple doesn't install things into /usr/local, you do. You had a bad  
copy of libreadline installed and it was causing problems.

Daniel J. Luke
| *---------------- dluke at ----------------* |
| *-------------- -------------* |
|   Opinions expressed are mine and do not necessarily   |
|          reflect the opinions of my employer.          |

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url :

More information about the macports-users mailing list