selfupdate failing under Leopard (yes I read the other posts about this)

Stuart Tannehill stuart at
Fri Nov 16 06:11:23 PST 2007

OK, MacPorts is working fine. I can add ports, upgrade them, etc. I cannot,
however, run selfupdate. The latest Xcode is installed, X11 is as well. No
ports are being blocked.

I ran the install commands manually. Configure completes successfully but
Make fails with the following error: "ld: warning in
/usr/local/lib/libreadline.dylib, file is not of required architecture"

So I used MacPorts to update the copy of libreadline.dylib in /opt to the
latest version, copied it over to /usr/local/lib and then ran selfupdate
again. It worked properly. I did switch back to the original version of
libreadline.dylib because I don't want to screw up anything Apple has going
on with it. Ya never know.

Given this I'd say, unless this was somehow specific to me alone, either the
selfupdate process should be modified as it is, under certain situations,
not working in its current form or their may be a bug to file with Apple.
Any ideas from you all? Regardless here is a solution that may be useful to
others (certainly more useful than the ever annoying yet omnipresent
response "Works for me").
View this message in context:
Sent from the MacPorts - Users mailing list archive at

More information about the macports-users mailing list