wireshark crashing

caliel at caliel.no-ip.org caliel at caliel.no-ip.org
Sat Nov 24 11:52:53 PST 2007

Did you try updating Xquartz to 1.2a11?  Instructions are at
http://www.x.org/wiki/XDarwin .  Doing this solved the problem for me.


On Sat, 24 Nov 2007 15:52:31 +0000, Mark Lucas <mllists at arc.co.uk> wrote:
> Having noted the various discussion regarding problems with wireshark I
> have tried everything to get it working , deleting all binaries,
> reinstalling MacPorts, compiling without X11 running, updating etc.
> nothing seems to work.
> I have found that if I run wireshark with the 'Automatic Scrolling in
> capture' turned OFF it does not crash. However if I scroll down to the
> bottom of the Packet List pane whilst in capture mode wireshark crashes.
> Similarly if I have 'Automatic Scrolling in live capture' turned ON
> wireshark crashes when the pane fills up and it tries to draw information
> on the bottom line of the Packet List pane i.e as it tries to
> automatically scroll.
> This problem existed for me with the latest version of wireshark even
> under Tiger.
> sudo -b wireshark
> returns this in the terminal window when it crashes;-
> The program 'wireshark' received an X Window System error.
> This probably reflects a bug in the program.
> The error was 'BadMatch (invalid parameter attributes)'.
>   (Details: serial 42521 error_code 8 request_code 152 minor_code 4)
>   (Note to programmers: normally, X errors are reported asynchronously;
>    that is, you will receive the error a while after causing it.
>    To debug your program, run it with the --sync command line
>    option to change this behavior. You can then get a meaningful
>    backtrace from your debugger if you break on the gdk_x_error()
> function.)
> OSX 10.5.1  G4 dual 1.3 GHz
> _______________________________________________
> macports-users mailing list
> macports-users at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo/macports-users

More information about the macports-users mailing list