What is MacPort 1.5 trying to pipe the gzip output to?

Ryan Schmidt ryandesign at macports.org
Sun Nov 25 10:48:01 PST 2007

On Nov 25, 2007, at 12:12, Jesse Ohlsson wrote:

> 	I installed the Xcode and X11, then the latest MacPorts and  
> successfully updated it as well.  I am ultimately trying to get  
> wireshark running.  This is the failure message I get:
> [g5:~] jess% sudo port install wireshark
> --->  Extracting expat
> Error: Target org.macports.extract returned: shell command " cd "/ 
> opt/local/var/macports/build/ 
> _opt_local_var_macports_sources_rsync.macports.org_release_ports_textp 
> roc_expat/work" && gzip -dc /opt/local/var/macports/distfiles/expat/ 
> expat-2.0.1.tar.gz | -xf - " returned error 127
> Command output: sh: -xf: command not found
> gzip: stdout: Broken pipe
> Error: The following dependencies failed to build: glib2 gettext  
> expat libiconv pkgconfig gtk2 atk cairo fontconfig freetype zlib  
> libpng render xrender jpeg pango Xft2 xorg-xproto xorg-util-macros  
> tiff libpcap openssl
> Error: Status 1 encountered during processing.
> I tried installing port fping and got the same error.
> Is this a simple fix?  Has anyone else seen this?  I'd sure  
> appreciate any help.

Haven't seen this problem before. That's supposed to be a tar command  
the output of gzip is being piped to.

Exactly what version of MacPorts do you have? What version of Xcode?  
What version of Mac OS X? What kind of Mac (Intel or PowerPC)?

More information about the macports-users mailing list