problem initializing macports

Ryan Schmidt ryandesign at
Sun Nov 25 10:54:30 PST 2007

What Mac do you have? Did you previously have a different Mac, back  
when you originally installed MacPorts? Maybe you used Migration  
Assistant to transfer everything (including MacPorts) from the old  
Mac to the new Mac? IF the old Mac was PowerPC-based and the new one  
is Intel-based, that could explain the error you're seeing, and you  
should really uninstall everything and start over. You can use "port  
installed" to see what ports are installed. Once you reinstall  
MacPorts, you can manually reinstall all those ports. To uninstall  
MacPorts, follow these instructions: 

If you're sure MacPorts previously worked on this Mac, then it  
shouldn't be necessary to uninstall, though I can't yet explain what  
else might be going on.

It also sounds like your PATH is not correct since it can't find the  
port command. Instructions for installing MacPorts properly,  
including setting the PATH (which doesn't really have anything to do  
with X11 in this case) are currently here:

On Nov 25, 2007, at 11:32, tania habib wrote:

> so do i need to uninstall the macport and reinstall it?
> I do not understand one thing as the last time it was working on my
> system and I installed various packages!
> Please let me know if there is a way of saving the packages I
> installed through macports before I delete it from my system?
> On Nov 25, 2007 6:21 PM, paul beard <paulbeard at> wrote:
>> On 11/25/07, tania habib <taniahabib at> wrote:
>>> Dear List,
>>> It has been long since I installed macports on my mac osx 10.4. I  
>>> used
>>> the ports to install many packages but then I went on to do  some
>>> other things and did not use ports for a while. Last week, when I
>>> tried to intialize the port, it did not work!
>>> When I go to and X11 terminal and type port , it gives me the
>>> following error message
>>> Error: /opt/local/bin/port: Failed to initialize ports system, no
>>> suitable image found.  Did find:
>>>         /opt/local/share/darwinports/Tcl/pextlib1.0/Pextlib.dylib:
>>> mach-o, but wrong architecture
>> sounds like you have an Intel system with a PPC code base  
>> installed. the
>> problem isn't in your PATH, as it find port correctly, but can't  
>> run it.

More information about the macports-users mailing list