Problems with Tidy

David Moylan dave at
Fri Sep 14 13:14:29 PDT 2007

Ryan Schmidt wrote:
> On Sep 14, 2007, at 13:38, Jeff Stubbs wrote:
>> Tried to install tidy prior to installing php5 on my sandbox machine. 
>> The attempt resulted in this error:
>> --->  Building tidy with target all
>> DEBUG: Executing (tidy)
>> DEBUG: Environment:
>> DEBUG: Assembled command: 'cd 
>> "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_tidy/work/tidy" 
>> && make all'
>> make: *** No rule to make target `all'.  Stop.
>> Error: Target returned: shell command " cd 
>> "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_tidy/work/tidy" 
>> && make all " returned error 2
>> Command output: make: *** No rule to make target `all'.  Stop.
>> Warning: the following items did not execute (for tidy): 
>> org.macports.activate org.macports.destroot 
>> org.macports.install
>> Error: Status 1 encountered during processing.
>> What's weird, is that I successfully installed tidy (and php5) about 
>> 4-5 weeks ago both on the sandbox and this machine. Comparing the two 
>> portfiles (this machine and the attempted fresh install on the 
>> sandbox) showed only a different time stamp & commit email address and 
>> additional livecheck directives. Everything else looked unchanged.
> I can confirm the problem, and don't know yet why it happens.
What platform on you trying to install on?  This is the same error I 
reported on esound, and libmng on a PBook G4 10.4.10 and in those cases 
seems to be a bug in the 'configure' script generated by autoconf.  The 
configure script does not produce any output when run and does not 
produce a Makefile, but exits 0, so no error is reported in that step. 
Since there is no Makefile you get an error at the next step (make) 
about 'no rule'.

> _______________________________________________
> macports-users mailing list
> macports-users at

More information about the macports-users mailing list