SOLVED: autoconf/configure problems

David Moylan dave at
Tue Sep 18 19:27:15 PDT 2007

I tried re-installing the port of m4, which made no difference with my 
install problem, then I reviewed the m4 description at and saw that it tries to install the binary as gm4.

`which m4` returned /usr/bin/m4 (version 1.4.2)


`which gm4` returned /opt/local/bin/gm4 (version 1.4.10)

Guessing that the build tools might look for m4 before gm4 I moved 
/usr/bin/m4 to /usr/bin/m4.old, then did a clean and install on libmng.

It worked!

libmng is now installed.

If you're having trouble with no Makefile being generated and 'no rule' 
errors, have a look at your path for old versions of m4.


David Moylan wrote:
> I'm still trying to track down the bug in the port for libmng.  I've 
> tried to contact the maintainer but have heard nothing.  In the build 
> process it appears that autoconf generates a configure script, but 
> executing 'configure' does nothing.  It does not go through the normal 
> checks and it does not create a Makefile it simply prints nothing and 
> exits.  Without the Makefile the installation can't proceed.
> config.log shows exit 0.
> My ports installation is up to date and synced.
> I'm on a PBook G4 with 10.4.10
> Dave
> _______________________________________________
> macports-users mailing list
> macports-users at

More information about the macports-users mailing list