autoconf/configure problems

Ryan Schmidt ryandesign at
Fri Sep 21 12:47:35 PDT 2007

On Sep 18, 2007, at 21:27, David Moylan wrote:

> I tried re-installing the port of m4, which made no difference with  
> my install problem, then I reviewed the m4 description at  
> and saw that it tries to install the binary as gm4.

Please do not use any information obtained from It  
is a rogue site not affiliated with the MacPorts project.

> `which m4` returned /usr/bin/m4 (version 1.4.2)
> while
> `which gm4` returned /opt/local/bin/gm4 (version 1.4.10)
> Guessing that the build tools might look for m4 before gm4 I moved / 
> usr/bin/m4 to /usr/bin/m4.old, then did a clean and install on libmng.
> It worked!
> libmng is now installed.
> If you're having trouble with no Makefile being generated and 'no  
> rule' errors, have a look at your path for old versions of m4.

/usr/bin/m4 is provided by Mac OS X. You should not need to move it.  
If you do, then that is merely a workaround. It sounds like a more  
permanent fix for the libmng portfile is still required. Please file  
a bug in Trac and assign it to the maintainer and Cc the maintainer  
and yourself.

More information about the macports-users mailing list