Activate never completes

Michael D. Johas Teener mike at
Sun Sep 23 21:34:16 PDT 2007

See below ...

On 9/21/07 1:08 PM, "Ryan Schmidt" <ryandesign at> wrote:>
> On Sep 18, 2007, at 16:04, Michael D. Johas Teener wrote:
>> The last few installs that I have attempted have hung during the
>> activate
>> phase ... I have terminated the processes and tried an explicit
>> activate
>> command, but that hangs, too. Now I have a number of intalled-but-
>> inactive
>> ports hanging around. For instance:
>> mikes-brcm-mbp:~ mikejt$ port installed
>> The following ports are currently installed:
>>   aquaterm @1.0.1_0+darwin_8
>>   expat @2.0.0_1
>>   expat @2.0.1_0 (active)
>>   fontconfig @2.4.2_0+macosx
>>   freetype @2.3.5_0
>>   gawk @3.1.5_2 (active)
>>   gettext @0.14.6_0
>>   gettext @0.16.1_0 (active)
>>   libiconv @1.10_1+darwin_8
>>   libiconv @1.11_4+darwin_8 (active)
>>   libpcap @0.9.5_1 (active)
>>   pkgconfig @0.22_0+universal (active)
>>   XFree86 @4.7.0_0+macosx (active)
>>   zlib @1.2.3_1 (active)
>> mikes-brcm-mbp:~ mikejt$ sudo port activate freetype
>> --->  Activating freetype
>> Then nothing ... just dead air .. same thing if I try to activate
>> aquaterm
>> ...
> Please try with debug and verbose output.
> sudo port -dv activate freetype
> Either it will show that something is progressing, though slowly, in
> which case let it go, or it will hang at one spot, and if so, show us
> the last few lines.
Hmm. Oddly enough, the activate of freetype worked perfectly this time. Dang
if I know what changed since I had the problem. I'm try to install gnuplot
and NOW I get the following for the last few lines ...

 gcc -DHAVE_CONFIG_H -I. -I. -I. -I/opt/local/include/freetype2
-I/opt/local/include -I/opt/local/include -I/usr/X11R6/include -O2 -MT
gdkanji.lo -MD -MP -MF .deps/gdkanji.Tpo -c gdkanji.c  -fno-common -DPIC -o
gdkanji.c:30: error: conflicting types for 'libiconv'
/opt/local/include/iconv.h:83: error: previous declaration of 'libiconv' was
gdkanji.c:42: error: conflicting types for 'libiconv'
/opt/local/include/iconv.h:83: error: previous declaration of 'libiconv' was
make[2]: *** [gdkanji.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Warning: the following items did not execute (for gd2):
org.macports.activate org.macports.destroot
Error: The following dependencies failed to build: gd2 ncurses ncursesw
pdflib readline teTeX ghostscript gzip gsed texi2html texinfo
Error: Status 1 encountered during processing.

----- Michael D. Johas Teener - mike at ----- --- PGP ID 0x3179D202

More information about the macports-users mailing list