Problem with MacPorts on OS X Leopard

Ryan Schmidt ryandesign at
Mon Aug 4 22:34:59 PDT 2008

On Aug 4, 2008, at 20:19, Mark Hattam wrote:

> Ryan Schmidt wrote:
>> On Aug 4, 2008, at 18:02, Mark Hattam wrote:
>>> I'm using 10.4.11 on a 667 MHz G4Ti laptop at the moment. (won't  
>>> run 10.5.x)
>> If you have .bash_profile, then modify .bash_profile (it takes  
>> precedence over .profile). For example, put /opt/local into your  
>> PATH by adding a line like:
>> export PATH=/opt/local/bin:/opt/local/sbin:$PATH
>> Although I see this is in your env:
>>> PATH=/bin:/sbin:/opt/local/bin:/usr/bin:/usr/sbin:~/bin:/usr/ 
>>> local/bin
>> So that means you already have a line somewhere else which is  
>> adding /opt/local/bin, though into the middle of your PATH. I  
>> prefer to add it at the beginning of PATH so that MacPorts- 
>> installed software takes precedence over Apple-provided software,  
>> as opposed to the reverse, but that's your choice.
>> Also, I see you have /usr/local/bin in your PATH. Note that having  
>> software installed in /usr/local can be problematic for MacPorts  
>> and is therefore not recommended.
>> There is a bug in the MacPorts 1.6.0 disk image installer which  
>> prevents it from creating the .profile for you. This is discussed  
>> in the FAQ:
>> But like I say .bash_profile takes precedence over .profile, so  
>> even running the postflight manually wan't set up  
>> your .bash_profile for you.
>> Off-topic, but if you want to run Leopard on your PowerBook,  
>> Leopard Assist may help. I'm successfully running Leopard on a 466- 
>> MHz Power Mac G4 using it.
> Running the PostFlight command line doesn't work ...
> Powerbook:~ markhattam$ $ curl -O 
> repository/macports/branches/release_1_6/base/portmgr/dmg/ 
> postflight && bash postflight
> -bash: $: command not found
> I just tried it to see what it puts into .profile ... even if it'll  
> never use it. But still.

You're not meant to type the dollar sign at the terminal. The dollar  
sign is meant to represent your terminal's prompt. Type (or copy/ 
paste) everything after the dollar sign.

> /usr/local/bin doesn't exist, and I've never knowingly installed  
> anything in /usr/local
> Powerbook:~ markhattam$ cd /usr/local/bin/
> -bash: cd: /usr/local/bin/: No such file or directory

Ah, ok, that's good then, from the MacPorts perspective.

> Powerbook:~ markhattam$ cd /usr/local/   Powerbook:/usr/local  
> markhattam$ ls -la
> total 0
> drwxr-xr-x    3 root  wheel  102 Mar 20 23:15 .
> drwxr-xr-x   11 root  wheel  374 May 24 22:50 ..
> drwxr-xr-x    4 root  wheel  136 Mar 20 23:15 hermes
> But a little quick Googling tells me that hermes is Rogue Amoeba's  
> Instant Hijack code, which works fine for me. So that can stay  
> where it is.

That's not a problem. As long as it's in a subdirectory of /usr/local  
it can't interfere. But if you have things in /usr/local/bin or /usr/ 
local/lib those can and do interfere in bad ways with some MacPorts  

> I put the line you suggested into .bash_profile ... but now after  
> re-running Terminal, and doing "env" it shows me
> Powerbook:~ markhattam$ env
> TERM_PROGRAM=Apple_Terminal
> TERM=xterm-color
> SHELL=/bin/bash
> USER=markhattam
> PHP_PEAR_PHP_BIN=/opt/local/bin/php
> PATH=/opt/local/bin:/opt/local/sbin:/bin:/sbin:/opt/local/bin:/usr/ 
> bin:/usr/sbin:~/bin:/usr/local/bin
> PWD=/Users/markhattam
> LANG=en_US.UTF-8
> HOME=/Users/markhattam
> LOGNAME=markhattam
> _=/usr/bin/env
> which looks like it pre-pended what was there before with the new  
> bits, so now I have /opt/local/bin twice.

Exactly. That's what the command I gave does. It prepends the  
MacPorts paths to whatever might already be in your PATH. Usually  
that's what you want. In your case, you've already set the PATH from  
elsewhere, so you could go to that elsewhere, wherever it is, and  
change the PATH there instead if you want.

> So I did it again, but with this line in .bash_profile
> export PATH=/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/ 
> sbin:~/bin
> and now "env" shows me
> PATH=/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/ 
> Users/markhattam/bin
> which seems to have automatically converted the ~/bin to /Users/ 
> markhattam/bin
> that is probably OK as I don't have a ~/bin directory anyway.

Ok. ~/bin isn't usually in the PATH either, so somewhere you must  
have another bash configuration file which is getting used which is  
adding /opt/local/bin, /usr/local/bin and ~/bin to your PATH. Doesn't  
really matter now, since you're overwriting the PATH in  
the .bash_profile now.

> As for 10.5 ... I can't see the G4Ti 667 MHz listed on that site at  
> all ...

Huh, you're right. The LeopardAssist homepage doesn't seem to mention  
portable Macs at all. I filed a bug in their issue tracker, though  
they haven't touched the bug I filed a month ago so maybe they're not  
paying attention. 

> nor is it in the site that they reference for  
> model details.

Looks like either the top-of-the-line "PowerBook G4 (Gigabit  
Ethernet)" model or the bottom-of-the-line "PowerBook G4 (DVI)" model: 

If your computer has a DVI port, then it's the "DVI" model. If not,  
it's the "Gigabit Ethernet" model.

> I'm not that desparate about 10.5 on this Mac. The screen's hinges  
> are both broken, the battery only lasts between 5 and 10 minutes,  
> it's getting old and sooner or later I'll get a new Powerbook and/ 
> or iMac which will run a lot faster ... just a case of when.
> I've tried before with "locked out" upgrades, eg running 9.2.2  
> (IIRC) on my Umax S900 clone with G3 card ... it ran faster as more  
> code was PPC enabled, but it also tended to lock up more. So it's  
> back on 9.1 and is very stable.

The Leopard installer's only determination for whether your computer  
will work is whether its processor speed is at least 867 MHz. So  
LeopardAssist fakes the installer out by telling your computer's  
OpenFirmware to lie about its processor speed during the installation  
and say it is 867 MHz, even if it's less.

The PowerBook G4 (Gigabit Ethernet) was announced October 2001 and  
the PowerBook G4 (DVI) was announced April 2002. My Power Mac G4  
(Digital Audio) was announced January 2001, and I have Leopard  
working on it. So since your PowerBook has newer technology in it  
than my Power Mac, I would expect Leopard to work on it.

I did have horrible performance in the DVD Player until I copied the  
video driver for my G4's graphics card (an ATI Rage 128 Pro) from a  
Tiger installation. Leopard presumably no longer included that driver  
because no machine that officially supports Leopard ever came with  
that graphics card. So possibly you'll have to fish for some older  
drivers from your Tiger installation too to get decent video  

More information about the macports-users mailing list