couldn't change working directory to...

Michael Thon mike.thon at
Thu Aug 7 03:20:06 PDT 2008

I am writing a new portfile for a package but I keep getting errors  
during the installation step:

--->  Staging hmmer into destroot
--->  Installing hmmer 2.3.2_0
couldn't change working directory to "/opt/local/var/macports/build/ 
_Users_mike_macports_dports_science_hmmer/work/destroot": no such file  
or directory
--->  Activating hmmer 2.3.2_0
Error: Target org.macports.activate returned: Image error: Source  
file /opt/local/var/macports/software/hmmer/2.3.2_0 does not appear to  
exist (cannot lstat it).  Unable to activate port hmmer.
Error: Status 1 encountered during processing.

The package uses a standard configure script so I thought this one  
would be easy.  I tried the usual 'sudo port clean' before I ran 'sudo  
port install' but it still won't go.  Any ideas? I pasted the Portfile  
at the end of this message.

name            hmmer
version         2.3.2
description     Biological sequence analysis using profile HMMs

long_description \
     Profile hidden Markov models (profile HMMs) can be used to do  
sensitive \
     database searching using statistical descriptions of a sequence  
family's \
     consensus. HMMER is a freely distributable implementation of  
profile HMM \
     software for protein sequence analysis.

maintainers     mike.thon at
categories      science
platforms       darwin
fetch.use_epsv  no
checksums       md5 5f073340c0cf761288f961a73821228a

More information about the macports-users mailing list