I cannot build gcc3.3 or 3.4

Ryan Schmidt ryandesign at macports.org
Sun Aug 24 20:59:54 PDT 2008

On Aug 24, 2008, at 13:10, Da Zheng wrote:

> I run "sudo port install apple-gcc33", but get another error:
> /usr/bin/gcc-4.0  tclAppInit.o
> -L/opt/local/var/macports/build/ 
> _opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_ 
> apple-gcc33/work/build/tcl/unix
> -ltcl8.0  -lc \
>          -o tclsh
> make[1]: *** No rule to make target `all'.  Stop.
> make: *** [all-expect] Error 2
> It's too bad if gcc 3.x cannot be built in Leopard.

It's not really too bad; GCC 3 is obsolete and shouldn't really be  
used anymore.

> Actually what I really want is to build qemu.

Right. So qemu should be made to work with GCC 4. And the qemu port  
already has tons of patches to make it use GCC 4, though they're only  
used on Intel on Leopard and Tiger. It still uses GCC 3 on PowerPC on  
Leopard and Tiger. Are you on PowerPC or Intel?

I don't have Leopard with me at the moment but I can test on some  
Leopard systems in a few days.

Unfortunately the qemu port has no maintainer. Someone who is  
interested in the qemu software should adopt the port and fix any  

> Does anyone know how to install qemu in Leopard?
> I installed Q, a port of qemu for Leopard, but it doesn't work well.
> Any ideas?
> Zheng Da
> Harry van der Wolf wrote:
>> I see.
>> Can you try to install apple-gcc33 instead of gcc34 or gcc33, so  
>> "sudo
>> port install apple-gcc33"?
>> I'm affraid though it won't work. Tiger came with 4.01 for Intel and
>> 3.3 for PPC. On Leopard both ppc and i386 are now 4.x. I'm affraid
>> Apple dropped support for 3.3 on Leopard.
>> Harry
>> 2008/8/24 Da Zheng <zhengda1936 at gmail.com  
>> <mailto:zhengda1936 at gmail.com>>
>>     Hi,
>>     I tried to install qemu with macports, and it suggested me to
>>     install gcc 3.x first.
>>     da-zhengs-macbook:gcc-3.3 dazheng$ sudo port install qemu
>>     --->  Configuring qemu
>>     Error: Target org.macports.configure returned: configure failure:
>>     shell command " cd
>>     "/opt/local/var/macports/build/ 
>> _opt_local_var_macports_sources_rsync.macports.org_release_ports_emul 
>> ators_qemu/work/qemu-0.9.0"
>>     && ./configure --prefix=/opt/local --enable-coreaudio
>>     --enable-cocoa " returned error 1
>>     Command output: WARNING: "gcc" looks like gcc 4.x
>>     Looking for gcc 3.x
>>     gcc 3.x not found!
>>     QEMU is known to have problems when compiled with gcc 4.x
>>     It is recommended that you use gcc 3.x to build QEMU
>>     To use this compiler anyway, configure with --disable-gcc-check
>>     Error: Status 1 encountered during processing.
>>     Zheng Da
>>     Harry van der Wolf wrote:
>>         Why do you need gcc 3.3?
>>         If you are on Leopard and you have macports, you can install
>>         qemu from macports. macports has a qemu and a qemu-usermode
>>         port. Did you already try these?
>>         Hary
>>         2008/8/24 Da Zheng <zhengda1936 at gmail.com
>>         <mailto:zhengda1936 at gmail.com> <mailto:zhengda1936 at gmail.com
>>         <mailto:zhengda1936 at gmail.com>>>
>>            Hello,
>>            I try to install gcc3.x because I want to install qemu.
>>            but I cannot install gcc3.3 or 3.4.
>>            I use Mac OS X v10.5.4, and I have gcc v4.0.1.

More information about the macports-users mailing list