I cannot build gcc3.3 or 3.4

Da Zheng zhengda1936 at gmail.com
Sun Aug 24 23:44:06 PDT 2008

Ryan Schmidt wrote:
> On Aug 24, 2008, at 13:10, Da Zheng wrote:
>> I run "sudo port install apple-gcc33", but get another error:
>> /usr/bin/gcc-4.0  tclAppInit.o
>> -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_apple-gcc33/work/build/tcl/unix 
>> -ltcl8.0  -lc \
>>          -o tclsh
>> make[1]: *** No rule to make target `all'.  Stop.
>> make: *** [all-expect] Error 2
>> It's too bad if gcc 3.x cannot be built in Leopard.
> It's not really too bad; GCC 3 is obsolete and shouldn't really be 
> used anymore.
>> Actually what I really want is to build qemu.
> Right. So qemu should be made to work with GCC 4. And the qemu port 
> already has tons of patches to make it use GCC 4, though they're only 
> used on Intel on Leopard and Tiger. It still uses GCC 3 on PowerPC on 
> Leopard and Tiger. Are you on PowerPC or Intel?
> I don't have Leopard with me at the moment but I can test on some 
> Leopard systems in a few days.
> Unfortunately the qemu port has no maintainer. Someone who is 
> interested in the qemu software should adopt the port and fix any issues.
I use Intel. Could you tell where I can get the patches?
I find a website, but it has only the patch for the old qemu.
I tried Q, a Mac port of qemu, but Hurd doesn't work well in it.

Zheng Da

More information about the macports-users mailing list