vim-app (and vim) with +python fails on Leopard

chirayuk chirayu at
Sun Aug 31 22:01:30 PDT 2008

I've been trying rather unsuccessfully to build vim-app or vim.  I'm using
Leopard 10.5.1.  I removed MacPorts and reinstalled it (using the
instructions form the wiki page.)  (Frustrated, I tried installing git so I
could build from the original source, but alas, git didn't build either.)

Anyway, here's what it looks like (attached/linked):

Lines like

/usr/bin/gcc-4.0 -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MAC -fno-common
-fpascal-strings -Wall -Wno-unknown-pragmas -mdynamic-no-pic -pipe -I.
-Iproto -I/opt/local/include -DMACOS_X_UNIX -no-cpp-precomp
-I/Developer/Headers/FlatCarbon  -O
-o objects/os_macosx.o os_macosx.c

make me wonder if
is correct - shouldn't it use the macports version of python25 that it just
installed (btw, I've tried the port command by first installing python, then
installing python_select and selecting python25 both with also putting
/opt/local/bin at the beginning of PATH and without, and with explicitly
exporting PREFIX and prefix to /opt/local and without.)

Does anyone here know what I'm doing wrong or how I can fix this?

View this message in context:
Sent from the MacPorts - Users mailing list archive at

More information about the macports-users mailing list