trying to build gnucash

Ryan Schmidt ryandesign at
Mon Sep 8 22:13:01 PDT 2008

On Sep 8, 2008, at 21:47, nodje wrote:

> I had successfully build Gnucash in the past but its stopped  
> working because
> of some dependencies on Goffice.
> I've never been able to upgrade it.
> I tried sudo port -ufn upgrade gnucash but it ended up in:
> checking for GLIB - version >= 2.6.0... no
> *** Could not run GLIB test program, checking why...
> *** The test program failed to compile or link. See the file  
> config.log for
> the
> *** exact error that occured. This usually means GLIB is incorrectly
> installed.
> configure: error:
> *** GLIB >= 2.6 is required to build Gnucash; please make sure you  
> have the
> *** development headers installed. The latest version of GLIB is
> *** always available at
> Error: Status 1 encountered during processing.
> I don't really understand this actually. Why is Macport not able to  
> treat
> glib as a dependency and update it? I'd be happy to upgrade it  
> myself but
> there's many glib available (from 'port installed').
> What am I supposed to do here? I'm looking at
> to build
> a Quartz compatible version of gnucash but I'd rather have it built  
> with
> port.

What version of glib2 is installed and active? Many older versions  
may well be installed if you've done many upgrades in the past, but  
only one is active. Try:

port installed glib2

The current version of glib2 is 2.16.5 which should satisfy the  
dependency. If somehow you have an older version than that installed  
and active, then:

sudo port upgrade glib2

Or attach the aforementioned config.log so we can see what's going  

More information about the macports-users mailing list