MacPorts-1.6.0 Won't Build

Bryan Blackburn 0x62_0x6c_0x62 at
Sat Sep 13 13:29:46 PDT 2008

On Sat, Sep 13, 2008 at 01:34:27PM -0600, Etherous said:
> Running MacBook: Intel Core Duo with Mac OS 10.5.4
> I already tried the DarwinPorts-1.6.0-10.5-Leopard.dmg version. The .pkg 
> SEEMED to run successfully, but whatever it did, it didn't install 
> DarwinPorts.

Where did you find a DarwinPorts 1.6 DMG?  DarwinPorts ended prior to 1.6 so
all DMG's [1] should be called MacPorts-1.6.0*.

> So next, I tried to manually build the MacPorts-1.6.0.tar.gz 
> version. However, during ./configure, the following was displayed 
> immediately before terminating:
> configure: Using Apple Objective-C runtime
> checking for Apple Foundation library... no
> configure: WARNING: GNUSTEP_SYSTEM_ROOT is not defined in your  
> environment, preventing the use of GNUstep's Foundation library
> configure: error: Could not find a working Foundation implementation

Make sure you have Xcode installed, as this is probably failing to find all
the necessary bits for compilation (the runtime stuff is obviously installed
for basic OS functionality but I don't believe headers are by default).  
You'll need Xcode anyway to build ports once MacPorts is successfully 


[1] - <>

> I know for a fact the Apple Foundation library exists (obviously) and, to 
> no avail, tried setting the following two environment variables:
> APPLE_FOUNDATION_LIBS="-framework Foundation"
> APPLE_FOUNDATION_CFLAGS="-framework Foundation"
> I could use some help at this point. Googling found absolutely nothing I 
> could use. If someone could either help me to fix the ./configure or  
> figure out where the package from the DMG installed to, I would greatly 
> appreciate it.

More information about the macports-users mailing list