MacPorts-1.6.0 Won't Build

Etherous etherous at
Sat Sep 13 12:34:27 PDT 2008

Running MacBook: Intel Core Duo with Mac OS 10.5.4

I already tried the DarwinPorts-1.6.0-10.5-Leopard.dmg version.  
The .pkg SEEMED to run successfully, but whatever it did, it didn't  
install DarwinPorts. So next, I tried to manually build the  
MacPorts-1.6.0.tar.gz version. However, during ./configure, the  
following was displayed immediately before terminating:

configure: Using Apple Objective-C runtime
checking for Apple Foundation library... no
configure: WARNING: GNUSTEP_SYSTEM_ROOT is not defined in your  
environment, preventing the use of GNUstep's Foundation library
configure: error: Could not find a working Foundation implementation

I know for a fact the Apple Foundation library exists (obviously) and,  
to no avail, tried setting the following two environment variables:
APPLE_FOUNDATION_LIBS="-framework Foundation"
APPLE_FOUNDATION_CFLAGS="-framework Foundation"

I could use some help at this point. Googling found absolutely nothing  
I could use. If someone could either help me to fix the ./configure or  
figure out where the package from the DMG installed to, I would  
greatly appreciate it.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list