[SAMBA] Problem on AppleTV

steve@wamu p.witty at gmail.com
Sat Sep 27 13:23:43 PDT 2008

OK.  First let me apologize.  I know this is probably not the *best* place to
submit this question, but the awkwardtv.org forum seems to be all but dead. 

So let me just state the facts.

I have installed the Macports Samba3 package on my AppleTV (which runs a
stripped down version of OSX 10.4.9), and it is not working (it worked fine
on firmware 1.0 and 1.1... but now with firmware 2.1 it is no longer

I followed the instructions found 
http://wiki.awkwardtv.org/wiki/Enable_SAMBA_server here .  I have posted my
question to the the 
http://forum.awkwardtv.org/viewtopic.php?f=10&t=727&p=11498#p11498 AwkwardTV
forum .  I would appreciate any suggestions and/or input you all might be
able to provide.

My next step is to go pop in my OSX 10.4 installer DVDs, open the install
package up in Pacifist, grab the ktrace and kdump binaries and copy them
over to my AppleTV so I can run a trace on the daemons (smbd and nmbd) when
I try to start them up.  I try to start them with the following commands:

-bash-2.05b$ /opt/local/sbin/smbd -c /opt/local/etc/samba3/smb.conf
-bash-2.05b$ /opt/local/sbin/nmbd -c /opt/local/etc/samba3/smb.conf

I believe that once they're started, they should show up when I run

ps ax | grep smbd
ps ax | grep nmbd

But no dice.

Please help me out here folks!  I would really appreciate it.
View this message in context: http://www.nabble.com/-SAMBA--Problem-on-AppleTV-tp19698265p19698265.html
Sent from the MacPorts - Users mailing list archive at Nabble.com.

More information about the macports-users mailing list