[SAMBA] Problem on AppleTV

steve@wamu p.witty at gmail.com
Sat Sep 27 19:29:09 PDT 2008


Thanks for your reply!  I believe that the way I got the Samba3 package was
someone installed the Macports samba3 port, and then just tar'd up their
whole /opt directory to redistribute.  If you follow the link below (the one
with "Enable_SAMBA_server" in the address), you'll see what I mean.  

This package worked fine on the earlier version(s) of the AppleTV software.

Anyway, what kind of information would I need to gather in order to get some
help here?  Do you think doing a ktrace on the daemon is a good idea or
should I be looking elsewhere?

Thanks again!


Ryan Schmidt-24 wrote:
> On Sep 27, 2008, at 15:23, steve at wamu wrote:
>> I have installed the Macports Samba3 package on my AppleTV (which  
>> runs a
>> stripped down version of OSX 10.4.9), and it is not working (it  
>> worked fine
>> on firmware 1.0 and 1.1... but now with firmware 2.1 it is no longer
>> starting).
>> I followed the instructions found
>> http://wiki.awkwardtv.org/wiki/Enable_SAMBA_server here .  I have  
>> posted my
>> question to the the
>> http://forum.awkwardtv.org/viewtopic.php?f=10&t=727&p=11498#p11498  
>> AwkwardTV
>> forum .  I would appreciate any suggestions and/or input you all  
>> might be
>> able to provide.
>> My next step is to go pop in my OSX 10.4 installer DVDs, open the  
>> install
>> package up in Pacifist, grab the ktrace and kdump binaries and copy  
>> them
>> over to my AppleTV so I can run a trace on the daemons (smbd and  
>> nmbd) when
>> I try to start them up.  I try to start them with the following  
>> commands:
>> -bash-2.05b$ /opt/local/sbin/smbd -c /opt/local/etc/samba3/smb.conf
>> -bash-2.05b$ /opt/local/sbin/nmbd -c /opt/local/etc/samba3/smb.conf
>> I believe that once they're started, they should show up when I run
>> ps ax | grep smbd
>> or
>> ps ax | grep nmbd
>> But no dice.
> I've never set up Samba myself, never used the MacPorts samba3 port,  
> never used an AppleTV, certainly never tried to modify its software...
> All I can suggest is to try installing samba3 with MacPorts on a  
> normal Mac. Does it work there? If no, then perhaps we can help;  
> otherwise the problem is unique to the AppleTV setup and you'd need  
> to gather more info.
> _______________________________________________
> macports-users mailing list
> macports-users at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo.cgi/macports-users

View this message in context: http://www.nabble.com/-SAMBA--Problem-on-AppleTV-tp19698265p19708306.html
Sent from the MacPorts - Users mailing list archive at Nabble.com.

More information about the macports-users mailing list