Configure error macport - mkvToolnix

Mine i.cue at
Mon Sep 29 17:02:38 PDT 2008

Hi Ryan,

Seems the problem is near solved.  After reinstall with all the  
variants I was still
getting the unknown encoder error. So I looked in the directories to  
see what
had been install and then changed 'ffmpeg -i file.mkv -vn -acodec aac  
-ac 2 audio.aac'
to 'ffmpeg -i file.mkv -vn -acodec libfaac -ac 2 audio.aac' and it  
worked. The only problem
is the audio file created is loud and distorted. I have searched and  
found neroAACEnc,
but it does not have a macPorts port. Would it be possible to install  
this and other apps
into the same directory as macPorts using something like the following:
./configure --prefix=/opt/local

Am I right in assuming that if I point the configure to either /opt  
or /opt/local the app would be
install into the relevant folders?



On 28 Sep 2008, at 07:00, Ryan Schmidt wrote:

> On Sep 28, 2008, at 00:51, Mine wrote:
>> On 27 Sep 2008, at 05:36, Ryan Schmidt wrote:
>>> On Sep 26, 2008, at 20:54, Mine wrote:
>>>> I have uninstalled everything and started again. Installing  
>>>> mpeg4ip and mkvtoolnix
>>>> first, followed by ffmpeg, a52, faac, faad, lame, x264 and xvid.
>>>> I am not sure if this is the right place for this next question,  
>>>> but hopefully you or
>>>> someone else may have encountered this next problem.
>>>> I have been able to extract a video track from and .mkv file,  
>>>> but when I try to convert
>>>> the audio to aac using the following:
>>>> ffmpeg -i file.mkv -vn -acodec aac -ac 2 audio.aac
>>>>  I get  'unknown encoder aac'
>>>> It seems to start alright with the following:
>>>> FFmpeg version UNKNOWN, Copyright (c) 2000-2008 Fabrice Bellard,  
>>>> et al.
>>>>   configuration: --prefix=/opt/local --disable-vhook --mandir=/ 
>>>> opt/local/share/man --enable-shared --enable-pthreads --disable- 
>>>> mmx --cc=gcc-4.0 --enable-gpl --enable-liba52
>>>>   libavutil version: 49.7.0
>>>>   libavcodec version: 51.60.0
>>>>   libavformat version: 52.18.0
>>>>   libavdevice version: 52.0.0
>>>>   built on Sep 27 2008 00:52:03, gcc: 4.0.1 (Apple Computer,  
>>>> Inc. build 5370)
>>>> followed by many lines of this:
>>>> [matroska @ 0x1802800]Ignoring seekhead entry for ID=0x1549a966
>>>> [matroska @ 0x1802800]Ignoring seekhead entry for ID=0x1654ae6b
>>>> [matroska @ 0x1802800]Ignoring seekhead entry for ID=0x114d9b74
>>>> and ends with:
>>>> Input #0, matroska, from '/Users/TWcomputer/vid_convert/Thomson/ 
>>>> Thomson_WMV-HD_720p.mkv':
>>>>   Duration: 00:04:39.56, start: 0.000000, bitrate: N/A
>>>>     Stream #0.0: Attachment: 0x0000
>>>>     Stream #0.1: Video: h264, yuv420p, 1280x720 [PAR 1:1 DAR  
>>>> 16:9], 30.00 tb(r)
>>>>     Stream #0.2: Audio: vorbis, 44100 Hz, stereo
>>>> Unknown encoder 'aac'
>>>> I am not sure if ffmpeg has its own encoder or if it should try  
>>>> to use faac. Can anyone suggest how to
>>>> solve this one.
>>> According to "port info ffmpeg" and "port variants ffmpeg",  
>>> ffmpeg can use faac to encode aac audio and faad to decode aac  
>>> audio. Did you install ffmpeg with the faac and faad variants?  
>>> I'm thinking you didn't, because ffmpeg showed you its  
>>> configuration line above, and it doesn't include the options "-- 
>>> enable-libfaac" and "--enable-libfaad" which should appear if you  
>>> had used those variants.
>> After sending my email, I did some more searching and found a  
>> reference
>> to  "--enable-libfaac" and "--enable-libfaad".  If I was  
>> installing from Terminal
>> without macPorts I believe the following should work:
>> ./configure --enable-libfaac" and "--enable-libfaad
>>  but I don't know how to set this option in macPorts.
> If you take a look at the Portfile ("port cat ffmpeg") you'll see  
> that using the +faac variant adds the --enable-libfaac configure  
> option, and using the +faad variant adds the --enable-libfaad  
> configure option.
>> I have now reinstalled ffmpeg using the following,
>> sudo port install ffmpeg +a52 +faac +faad +gpl +lame +libogg  
>> +postproc +theora +vorbis +x264 +xvid
> So that should have been all you needed to do.
>> but I got an error 'unknown encoder aac' so it appears that I sill  
>> have to enable
>> these options. Could you tell me how to enable these options in  
>> macPorts.
> Beyond using the available variants, I can't help. I don't use  
> ffmpeg myself. You might want to contact the maintainer of the  
> ffmpeg port, or the authors of the ffmpeg software.
>> I also downloaded and installed ffmpeg-export-2008-09-26, faac,  
>> and faad outside
>> from the terminal without macPorts, to see if I could enable  
>> options. So I now have
>> two versions of these apps. Is there a simple way to delete the  
>> non-macports version.
>> Or can I get a list of where these apps install there files and  
>> delete them manually.
> Usually that would be specified by the configure option --prefix=/ 
> wherever. If you did not supply the --prefix flag to configure,  
> then usually they go in /usr/local. It's a bad idea to have things  
> in /usr/local while also trying to use MacPorts, so you should  
> remove what's in /usr/local.

More information about the macports-users mailing list