Configure error macport - mkvToolnix

Ryan Schmidt ryandesign at
Mon Sep 29 22:41:49 PDT 2008

On Sep 29, 2008, at 7:02 PM, Mine wrote:

> Seems the problem is near solved.  After reinstall with all the  
> variants I was still
> getting the unknown encoder error. So I looked in the directories  
> to see what
> had been install and then changed 'ffmpeg -i file.mkv -vn -acodec  
> aac -ac 2 audio.aac'
> to 'ffmpeg -i file.mkv -vn -acodec libfaac -ac 2 audio.aac' and it  
> worked. The only problem
> is the audio file created is loud and distorted. I have searched  
> and found neroAACEnc,
> but it does not have a macPorts port. Would it be possible to  
> install this and other apps
> into the same directory as macPorts using something like the  
> following:
> ./configure --prefix=/opt/local
> Am I right in assuming that if I point the configure to either /opt  
> or /opt/local the app would be
> install into the relevant folders?

The correct prefix would be /opt/local, not /opt. However, do not  
install software into the MacPorts prefix manually. MacPorts has its  
own prefix because it wants to be in control of what's in there. I  
recommend you make a port for neroAACEnc. The Guide [1] is a good  
place to learn how to write ports. I also find it valuable to just  
look at some of the existing portfiles to see how they do things.


More information about the macports-users mailing list