Macports X11 damaged?

ggrubbish at ggrubbish at
Thu Apr 2 08:48:43 PDT 2009


Sorry for the first email it slipped away. 
I'm completely new to macports, but have experience with linux debian distributions. I installed and updated apple X11 on a PPC 10.4.11.

I achieved to install some x applications successfully, but it seems that they are only functional if they are linked against the apple X11.


[16:36:58] [user at mac :~]$ > xdvi &
[1] 11376
[16:37:04] [user at mac :~]$ > dyld: Library not loaded: /opt/local/lib/libXaw.7.dylib
  Referenced from: /opt/local/bin/xdvi-xaw.bin
  Reason: image not found

[1]+  Trace/BPT trap          xdvi

I tried to install xpdf, but that didn't work.
I got some errors when starting xpdf:

Warning: Widget must be a VendorShell.
Error: attempt to add non-widget child "dsm" to parent "xpdf" which supports only widgets

I found similar Bug-Reports: [MacPorts] #18494 #18114 #18118

I tried this workaround:

    by raphael@

    A workaround is to add +system_x11 to /opt/local/etc/macports/variants.conf, so that by default the system X11 libraries (instead of the MacPorts libraries) are used.
    I fixed my problems with geomview by reinstalling geomview and all its dependencies with

        sudo port -f upgrade geomview

    This should also work with other openmotif based ports. 

This resulted in some errors:
_XFreePixmap referenced from libtk8 expected to be defined in /opt/local/lib/libX11.6.dylib
collect2: ld returned 1 exit status
make: *** [wish] Error 1

Full report here:

Then I got this error: 

$ > dyld: Library not loaded: /opt/local/lib/libXt.6.dylib
  Referenced from: /opt/local/bin/xpdf
  Reason: image not found

Then I tried this:

sudo port -f upgrade Xaw3d

without success:

After that I tried to install some xorg packages:

Then selfupdate and upgrade outdated.

I don't understand that at all.

Here is a locate libXt:

I got also errors on sudo port install xorg-server:

checking for XLIB... configure: error: Package requirements (x11) were not met:

No package 'x11' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XLIB_CFLAGS
and XLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

sudo port install x11 doesn't work either:

$ > sudo port install x11
Error: Port x11 not found

What's wrong?

Thank you in advance!

Kind regards

Gerhard G.

Neu bei WEB.DE: Kostenlose maxdome Movie-FLAT!

More information about the macports-users mailing list