Macports X11 damaged?

Ryan Schmidt ryandesign at
Mon Apr 6 03:04:01 PDT 2009

On Apr 2, 2009, at 10:48, ggrubbish at wrote:

> Sorry for the first email it slipped away.
> I'm completely new to macports, but have experience with linux  
> debian distributions. I installed and updated apple X11 on a PPC  
> 10.4.11.

Welcome to MacPorts! I'll try to answer your questions below.

> I achieved to install some x applications successfully, but it  
> seems that they are only functional if they are linked against the  
> apple X11.

The preferred way to use MacPorts with X11 apps now is to use the  
xorg ports that come with MacPorts. You don't need to do anything  
special to get these; simply installing the port you want will cause  
the required xorg ports to be installed as well.

> e.g.:
> [16:36:58] [user at mac :~]$ > xdvi &
> [1] 11376
> [16:37:04] [user at mac :~]$ > dyld: Library not loaded: /opt/local/ 
> lib/libXaw.7.dylib
>   Referenced from: /opt/local/bin/xdvi-xaw.bin
>   Reason: image not found
> [1]+  Trace/BPT trap          xdvi

Does /opt/local/lib/libXaw.7.dylib exist on your hard drive? It  
should. If it does not, is the xorg-libXaw port installed? It should  
be, since xdvi is part of the texlive_base port which declares a  
dependency on the xorg-libXaw port. You could try rebuild the xorg- 
libXaw port:

sudo port -nf upgrade xorg-libXaw

> I tried to install xpdf, but that didn't work.
> I got some errors when starting xpdf:
> Warning: Widget must be a VendorShell.
> Error: attempt to add non-widget child "dsm" to parent "xpdf" which  
> supports only widgets
> I found similar Bug-Reports: [MacPorts] #18494 #18114 #18118

#18494 is marked as a duplicate of #18114 which is marked as a  
duplicate of #18181 which is marked as fixed.

#18118 is not related; I assume that's a typo of #18181.

> I tried this workaround:
>     by raphael@
>     A workaround is to add +system_x11 to /opt/local/etc/macports/ 
> variants.conf, so that by default the system X11 libraries (instead  
> of the MacPorts libraries) are used.
>     I fixed my problems with geomview by reinstalling geomview and  
> all its dependencies with
>         sudo port -f upgrade geomview
>     This should also work with other openmotif based ports.

Ok, that suggestion was from here:

I personally would not recommend using the +system_x11 variant. I  
have not tried it myself. Note the advice from our X11 expert Jeremy:

"Also note that adding or removing +system_x11 variant should be done  
with caution and switching between these variants is not supported.  
You should do a complete rebuild of all ports that use X11 if you  
change between those variants if you want a usable system"

He provides instructions for doing that.

> This resulted in some errors:
> e.g.:
> _XFreePixmap referenced from libtk8 expected to be defined in /opt/ 
> local/lib/libX11.6.dylib
> collect2: ld returned 1 exit status
> make: *** [wish] Error 1
> Full report here:
> Then I got this error:
> $ > dyld: Library not loaded: /opt/local/lib/libXt.6.dylib
>   Referenced from: /opt/local/bin/xpdf
>   Reason: image not found
> 006989.html

I don't know specifically what's going on here but would first try  
rebuilding the affected ports.

> Then I tried this:
> sudo port -f upgrade Xaw3d
> without success:

I see that some ports' configure scripts are having trouble finding  
their dependencies, but I don't understand why.

Note that you almost never want to use the "-f" (force) flag without  
also using the "-n" (nonrecursive) flag with the "upgrade" command.

> After that I tried to install some xorg packages:
> Then selfupdate and upgrade outdated.
> I don't understand that at all.
> Here is a locate libXt:
> I got also errors on sudo port install xorg-server:
> checking for XLIB... configure: error: Package requirements (x11)  
> were not met:
> No package 'x11' found
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> Alternatively, you may set the environment variables XLIB_CFLAGS
> and XLIB_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.

This is mostly the same stuff, configure scripts not finding the  
dependencies, but I don't know why.

> sudo port install x11 doesn't work either:
> $ > sudo port install x11
> Password:
> Error: Port x11 not found
> What's wrong?

There is no port called "x11". There is a port "xorg-libX11"; perhaps  
that's what you meant.

More information about the macports-users mailing list