installed second MacPorts copy, now can't see installed ports

Joshua Root jmr at
Fri Apr 3 20:24:55 PDT 2009

Allen McBride wrote:
> I wanted to see if I could figure out what this "port mdmg" stuff is all
> about, so I tried to follow some advice Rainer gave me a month ago: I
> downloaded the MacPorts tarball, then did the following:
> 1) Temporarily removed /opt/local/bin and /opt/local/sbin from my path
> (I made this step up because, when I tried it without doing this first,
> I got an error during configuration about not having tcl threads).
> 2) ./configure --prefix=/opt/solfegetest
> 3) make
> 4) sudo make install
> 5) cd /opt/solfegetest/bin
> 6) sudo ./port -v selfupdate
> 7) restored my usual path
> 8) sudo port -v selfupdate (expected this to sync my main macports
> installation)
> Everything seemed to go fine, but now when I run "port installed", I get
> "No ports are installed."
> "which port" returns "/opt/local/bin/port", as expected.  I've never
> thought about the registry before, but it seemed like an obvious thing
> to think about now, and I see there are no files in
> /opt/local/var/macports/registry.

There never is; the registry currently keeps all its information under

> Where did I go wrong?  Can I undo this damage?

For multiple MP installs, you also need to pass --with-tclpackage to
configure. The default is /Library/Tcl. Your first install put files
here, which were subsequently overwritten by your second install.

To correct things, you first need to reinstall MP with the default
prefix and Tcl package dir, and then reinstall with the alternate prefix
and alternate Tcl package dir.

You may also want to pass a different --with-applications-dir, if you
are going to be installing GUI apps with both installs.

- Josh

More information about the macports-users mailing list