Firefox-x11 did not upgrade

robert delius royar apple at
Tue Apr 7 03:54:22 PDT 2009

Tue, 7 Apr 2009 (00:30 -0700 UTC) Jeremy Huddleston wrote:

> On Apr 3, 2009, at 17:53, Ryan Schmidt wrote:
>> On Apr 2, 2009, at 18:21, Frank J. R. Hanstick wrote:
>> > On Apr 2, 2009, at 1:57 PM, Bryan Blackburn wrote:
>> > 
>> > > On Thu, Apr 02, 2009 at 02:14:37AM -0700, Frank J. R. Hanstick said:
>> > > 
>> > > >  Upgrading Firefox-x11 resulted in the following error:
>> > > [...]
>> > > > In file included from nsNSSCleaner.h:127,
>> > > >                 from nsNSSCleaner.cpp:38:
>> > > > ../../../../dist/include/system_wrappers/certt.h:3:24: error: 
>> > > > certt.h: No
>> > > > such file or directory
>> > > 
>> > > That should be with the nss port, do you have that installed and at 
>> > > version
>> > > 3.12?  The current firefox-x11 (3.0.8_2) lists it as a dependency, so 
>> > > it
>> > > should have been installed...
>> > 
>> >  Being dependent on nss-3,12 explains why it is not installing because 
>> >  nss-3.12 fails to install (ticket 18930) leaving me with nss-3.11.9_0. 
>> >  Shouldn't a failure to install nss-3.12 cause the Firefox-x11 to abort 
>> >  during configuration rather than build?
>> You can bring that up with the developers of firefox if you like. Sounds 
>> like their configure script isn't properly detecting the required version 
>> of nss.
> It should be... It failed for me when I tried building against 3.11.9... of 
> course maybe that was when I was building 3.1b3... I don't remember... /shrug
> I still don't know why nss isn't building for some people.  In the mean time, 
> you can hopefully install firefox-x11-devel.  It's not building on intel 
> because of an annoying API bug... but I'll hopefully have a fix for that soon 
> (see the xorg-devel mailing list if you are masochistic about the X11 header 
> hell).

After you closed the bug "#14901: firefox-x11 does not provide 
file-selection browsers," I decided to upgrade.  Thank you for fixing 
that bug.  It was over a year old by the time I finally filed it, and 
you ficxed it within a day or so of being assigned the bug.

When I tried the new Portfile, I first ran uninstall firefox-x11. 
Then I tried to install the new version.  My 
Firefox-x11 was so old that the configure stage failed on a number of 
the required ports because of version.  Some were two versions older 
than configure needed.  It did not give me an error about heimdal.  Mine 
was a 0.x version--way out of date.  But the build failed on some of the 
security stuff.  I upgraded heimdal, cleaned firefox-x11, and started 

The next hurdle was nss/nspr.  Both were up to date, and the files that 
were showing the error were on the system.  What was missing in the 
--with-system version was an -I for the dirctory where macports stores 
the headers.  When I tried some hand compiling adding 
-I/opt/local/include/nss, the build ran OK.  However, there are too many 
of those references to make that solution work (without knowing where 
the gmake -I references are built.

I had another small glitch that resulted from one of the dependencies 
having built even though one of its dependencies (pango) was outdated.

After wrangling for a very long time to get firefox-x11 to build because 
it always stopped in either the nss or nspr part, I finally decided to 
        --with-system-nspr \
        --with-nspr-prefix=${prefix} \
        --with-system-nss \
        --with-nss-prefix=${prefix} \
from the Portfile, clean and retry.  I got all the way into late stages 
of desroot when it failed because a file it wanted to move into 
the destroot already existed there.
% port destroot firefox-x11
--->  Staging firefox-x11 into destroot
Error: Target org.macports.destroot returned: error copying 
to "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_firefox-x11/work/destroot/opt/local/share/applications/firefox.desktop": file already exists
Error: Status 1 encountered during processing.

(I retried this after cleaning and assuring that desroot was clear 
before trying to install again.)

After a third try I gave up on the Macports way, pushd'ed to the build 
directory and did a 'gmake install'

I know I broke the rules, but it's my personal machine, so I am not 
concerned.  Firefox works now fine as an X based browser--including 
using the file browser.

Dr. Robert Delius Royar                   Associate Professor of English
Morehead State University                             Morehead, Kentucky

More information about the macports-users mailing list