Firefox-x11 did not upgrade

Jeremy Huddleston jeremyhu at
Tue Apr 7 14:20:03 PDT 2009

On Apr 7, 2009, at 03:54, robert delius royar wrote:
> After you closed the bug "#14901: firefox-x11 does not provide file- 
> selection browsers," I decided to upgrade.  Thank you for fixing  
> that bug.  It was over a year old by the time I finally filed it,  
> and you ficxed it within a day or so of being assigned the bug.

Thanks, I'm trying to make it as usable as possible, so I have a solid  
browser to use with X11 to increase my own X11 app usage and hopefully  
find bugs before they reach users.  You may have noticed that firefox- 
x11-devel is there as well (which uses the packaged nss and nspr  
instead of the system one) as well as the new mozplugger port which  
lets you use xpdf and mplayer as plugins for related content.

> When I tried the new Portfile, I first ran uninstall firefox-x11.  
> Then I tried to install the new version.  My Firefox-x11 was so old  
> that the configure stage failed on a number of the required ports  
> because of version.  Some were two versions older than configure  
> needed.  It did not give me an error about heimdal.  Mine was a 0.x  
> version--way out of date.  But the build failed on some of the  
> security stuff.  I upgraded heimdal, cleaned firefox-x11, and  
> started over.

Sorry, I just came on board with the mozilla stuff as a way of testing  
X11.  I'm trying to piece together as much as possible and pushing  
issues upstream where appropriate (bug numbers are listed in the  
Portfile if you're interested).  I'd recommend filing a bug upstream  
if the version checks are insufficient (especially if that's still the  
case with 3.1b3).

> The next hurdle was nss/nspr.  Both were up to date, and the files  
> that were showing the error were on the system.  What was missing in  
> the --with-system version was an -I for the dirctory where macports  
> stores the headers.
> When I tried some hand compiling adding -I/opt/local/include/nss,  
> the build ran OK.  However, there are too many of those references  
> to make that solution work (without knowing where the gmake -I  
> references are built.

Interesting.  It should be finding them alright.  It is here on my  
systems (Leopard/ppc and Leopard/intel ... I haven't messed with my  
Tiger/ppc box in a while).  What do you see in config/ for  

What file is missing the -I... during the build?  Do you have the most  
up-to-date portfile?  This issue should be fixed using system-nss.patch:

--- config/	2009-03-29 22:07:24.000000000 -0700
+++ config/	2009-03-29 22:07:54.000000000 -0700
@@ -278,7 +278,7 @@ OS_LDFLAGS	= @LDFLAGS@


> I had another small glitch that resulted from one of the  
> dependencies having built even though one of its dependencies  
> (pango) was outdated.
> After wrangling for a very long time to get firefox-x11 to build  
> because it always stopped in either the nss or nspr part, I finally  
> decided to remove
>       --with-system-nspr \
>       --with-nspr-prefix=${prefix} \
>       --with-system-nss \
>       --with-nss-prefix=${prefix} \
> from the Portfile, clean and retry.  I got all the way into late  
> stages of desroot when it failed because a file it wanted to move  
> into the destroot already existed there.
> % port destroot firefox-x11
> --->  Staging firefox-x11 into destroot
> Error: Target org.macports.destroot returned: error copying "/opt/ 
> local/var/macports/sources/ 
> firefox-x11/files/share-applications-firefox.desktop" to "/opt/local/ 
> var/macports/build/ 
> _opt_local_var_macports_sources_rsync 
> .macports.org_release_ports_www_firefox-x11/work/destroot/opt/local/ 
> share/applications/firefox.desktop": file already exists
> Error: Status 1 encountered during processing.
> (I retried this after cleaning and assuring that desroot was clear  
> before trying to install again.)

That's odd.  How is it getting there?  Can you try saving the debug  
build log and sending it to me (or just grep through it yourself to  
look for 'firefox.desktop')?

> After a third try I gave up on the Macports way, pushd'ed to the  
> build directory and did a 'gmake install'
> I know I broke the rules, but it's my personal machine, so I am not  
> concerned.  Firefox works now fine as an X based browser--including  
> using the file browser.

Great... I'd still like to figure out your issues though...

Can you give 'firefox-x11-devel' a whirl.  It can live alongside  

More information about the macports-users mailing list