fails to build dbus

Ryan Schmidt ryandesign at
Sun Apr 12 17:10:36 PDT 2009

On Apr 12, 2009, at 16:27, Dimitri Hendriks wrote:

> I just installed macports, and wanted to install port lablgtk2.
> All went well (it takes hours though) until:
> --->  Fetching dbus
> --->  Attempting to fetch dbus-1.2.12.tar.gz from http:// 
> --->  Verifying checksum(s) for dbus
> --->  Extracting dbus
> --->  Applying patches to dbus
> --->  Configuring dbus
> --->  Building dbus
> --->  Staging dbus into destroot
> --->  Installing dbus @1.2.12_5
> --->  Activating dbus @1.2.12_5
> Error: Target org.macports.activate returned: Image error: /Library/ 
> LaunchAgents/org.freedesktop.dbus-session.plist already exists and  
> does not belong to a registered port.  Unable to activate port dbus.
> Error: The following dependencies failed to build: libgnomeui gnome- 
> keyring gconf dbus dbus-glib orbit2 libidl libgcrypt libgpg-error  
> libtasn1 libbonoboui gnome-vfs desktop-file-utils popt gnome-mime- 
> data libbonobo libgnome esound audiofile ocaml
> Error: Status 1 encountered during processing.
> I uninstalled dbus and tried again, but the same error message came  
> up.
> What can I do?

Welcome to MacPorts!

Had you previously installed or tried to install dbus-session either  
with or without MacPorts? Something has placed the file /Library/ 
LaunchAgents/org.freedesktop.dbus-session.plist on your hard drive  
and MacPorts doesn't think it did (though it could have, and then  
failed before recording that fact). In any case, remove that file and  
try again.

More information about the macports-users mailing list