sudo port install trac +mysql +postgres (install errors)

Ryan Schmidt ryandesign at
Sun Apr 12 18:33:45 PDT 2009

I'm out of my element with python so I can't help very much with the  
trac issue, but I'll try to answer some of your questions below.

On Apr 12, 2009, at 17:25, Bill Hernandez wrote:

> The earlier results, in my previous message were from my Tiger Server.
> When I tried to install trac on the server last night, it installed  
> python26.
> I installed trac on my iMac about a week ago, and it installed  
> python25.  Today when I checked 'outdated' it did not show trac  
> even though it does not have python26. It appears that even though  
> trac is now installing python26, $ 'port outdated' does not find  
> trac on my iMac workstation as needing upgrading ?

When trac was updated to use python26 instead of python25 in r49378  
the revision was bumped so if you had 0.11.4_0 or earlier you should  
be prompted via "port outdated" to upgrade to 0.11.4_1.

> I tried you suggestion using 'sudo port upgrade outdated' but the  
> installer did not seem to like that idea ?
> $ port installed            (the results are at the bottom of the  
> page)
> $ port outdated
> $ sudo port upgrade outdated
> which failed with an error...
> [2009.12.04](04:52PM) -> [roscoe] ~ $ port outdated
> The following installed ports are outdated:
> cyrus-sasl2                    2.1.21_0 < 2.1.22_0
> [2009.12.04](04:52PM) -> [roscoe] ~ $ sudo port upgrade outdated
> Password:
> --->  Configuring cyrus-sasl2
> Error: cyrus-sasl2 will not build when another version is active.
> Error: Please deactivate or uninstall cyrus-sasl2, and then install
> Error: the new version with `sudo port install cyrus-sasl2`.
> Error: Target org.macports.configure returned: cyrus-sasl2 upgrade  
> failed
> ERROR: Unable to upgrade port: 1

It's only cyrus-sasl2 specifically that does not like the idea. For  
cyrus-sasl2 specifically, you must follow the instructions it has  
printed for you. You must first deactivate the old cyrus-sasl2, and  
then install the new cyrus-sasl2. The new cyrus-sasl2 cannot be built  
while the old cyrus-sasl2 is active.

More information about the macports-users mailing list