sudo port install trac +mysql +postgres (install errors)

Bryan Blackburn blb at
Sun Apr 12 18:44:39 PDT 2009

On Sun, Apr 12, 2009 at 05:25:36PM -0500, Bill Hernandez said:
> Bryan,
> The earlier results, in my previous message were from my Tiger Server.
> When I tried to install trac on the server last night, it installed  
> python26.
> I installed trac on my iMac about a week ago, and it installed python25.  
> Today when I checked 'outdated' it did not show trac even though it does 
> not have python26. It appears that even though trac is now installing 
> python26, $ 'port outdated' does not find trac on my iMac workstation as 
> needing upgrading ?

trac was updated [1] to use python26 recently, so make sure everything is up
to date; 0.11.4 is the trac version in both cases, but revision 1 is where
python26 became the preferred python.

> At about the same time I also tried to install trac on the Tiger Server, 
> and the installer was not successful installing trac, but it did get 
> python25 installed.
> On my Server, now trac has successfully installed both pythons 25 and 26, 
> and no trac. Any suggestions ?
> Maybe I should try to uninstall python25 to see if MaPorts squaks ?

That would most likely fail since there are still quite a few ports which are
2.5-based instead of 2.6.

> These are from my iMac Leopard Workstation. I tried you suggestion using 
> 'sudo port upgrade outdated' but the installer did not seem to like that 
> idea ?
> $ port installed            (the results are at the bottom of the page)
> $ port outdated
> $ sudo port upgrade outdated
> which failed with an error...
> [2009.12.04](04:52PM) -> [roscoe] ~ $ port outdated
> The following installed ports are outdated:
> cyrus-sasl2                    2.1.21_0 < 2.1.22_0
> [2009.12.04](04:52PM) -> [roscoe] ~ $ sudo port upgrade outdated
> Password:
> --->  Configuring cyrus-sasl2
> Error: cyrus-sasl2 will not build when another version is active.
> Error: Please deactivate or uninstall cyrus-sasl2, and then install
> Error: the new version with `sudo port install cyrus-sasl2`.
> Error: Target org.macports.configure returned: cyrus-sasl2 upgrade failed

This is an issue with the cyrus-sasl2 port; some software doesn't build
cleanly when an earlier version is available, hence this needs the older
version deactivated or uninstalled prior to getting the latest version.  I
usually just force uninstall the old one then install the new one:

$ sudo port -f uninstall cyrus-sasl2
$ sudo port install cyrus-sasl2


[1] - <>


More information about the macports-users mailing list