texlive_base failed to build

Ryan Schmidt ryandesign at macports.org
Sun Feb 22 19:20:17 PST 2009

On Feb 22, 2009, at 18:17, David Epstein wrote:

> I'm aware that there is a bug report out on texlive_base, but is  
> there a
> work-around? I'm rather desperate, as I stupidly trashed my copy of  
> tetex
> before trying to install texlive. As a result none of the tex family
> programs are available to me, and I use them all the time. I tried the
> version of the final command you see below at the end of my error  
> message,
> that I found in one of the trac files, but it just reported  
> multiple symbol
> definitions.
> Could someone help me out here? I'm out of my depth. Thanks very much.
> Should I start again with a port clean command?
> In desperation, I downloaded MacTex (not via MacPorts), and the  
> installation
> seemed to go OK. But when I tried to use it, I got an error message  
> that
> /opt/local/bin/pdflatex didn't exist. I was surprised by this  
> unexpected
> interaction between MacPorts and MacTex. I then tried "port search  
> pdflatex"
> and was told "texshop". But when I successfully did a MacPorts port of
> texshop, pdflatex still wasn't there. How can I find a port which  
> will give
> me a copy of /opt/local/bin/pdflatex?

On my system, the port texlive provides the file /opt/local/bin/ 
pdflatex. I foud this out by typing "port provides /opt/local/bin/ 
pdflatex", however that will not work if you do not already have the  
port installed, so that's not useful in your case.

> Here is the error I got from trying to build texlive_base
> --->  Building texlive_base


> /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: can't locate file  
> for: -lXaw
> collect2: ld returned 1 exit status
> make[2]: *** [xdvi-xaw.bin] Error 1
> make[1]: *** [all] Error 1
> make: *** [all] Error 1

I do not see a ticket filed for this error message.

The port xorg-libXaw should provide the Xaw library that it says it  
cannot find. texlive_base declares a dependency on xorg-libs which  
declares a dependency on xorg-libXaw, so it should be there. Is xorg- 
libXaw installed and active on your system? If not, install or  
activate it. Or if so, try rebuilding it.

More information about the macports-users mailing list