Case of port names?

Ryan Schmidt ryandesign at
Fri Feb 27 16:04:43 PST 2009

On Feb 27, 2009, at 17:54, Scott Haneda wrote:

> Stumped entirely, if I run a clean --dist, I will get a checksum  
> mismatch with the port name set to ASSP, if I run the port name set  
> to assp, I do not.
> name			    assp
> version
> categories		    mail
> maintainers
> description		    Anti-Spam SMTP Proxy (ASSP) Server
> long_description	    tba
> homepage
> platforms		    darwin
> master_sites		    sourceforge
> use_zip			    yes
> checksums                   md5     95191c8a081601a5b80557ad606d867a \
>                             sha1     
> 67d9587d78e8c6d2696ff13d5ae323bb513421f1 \
>                             rmd160   
> 0e0cc34e56a3d54e06f4d6a3c123322431d33dcc
> depends_run		    bin:perl:perl5.8
> distname		    ASSP_${version}-Install
> worksrcdir		    ${distname}/ASSP
> set assp_base		    ${prefix}/var/ASSP
> # This distribution is just perl files
> use_configure		    no

Yes, because with the port name set to "ASSP" it is trying to  
download from "" which doesn't  
exist. "" is where you need to  
download from, hence you need to either name the port "assp" or set  
the master_sites to "sourceforge:assp". "master_sites sourceforge" is  
equivalent to "master_sites sourceforge:${name}"

> Some side questions, I know about `port contents`, is there a  
> command to tell me the base in which the install has happened in,  
> other than looking through `port contents`?  I want to cd `port  
> something` and get right to where the installed files are.

Most ports install all over ${prefix} so there is no command for that.

> Maybe it is that I am just testing a lot, but a `port uninstall  
> ASSP` does not remove the files in /opt/local/var/ASSP, at least,  
> not all the time,  What is the best way to get the distfiles, work,  
> and installed files gone, as well as unregister them?

"port uninstall ASSP" should always uninstall all files registered to  
your port. If it doesn't, then the files were not registered to the  

I assume the portfile you posted above is incomplete because it  
doesn't work for me; it says "make: *** No rule to make target  
`all'.  Stop." So I can't test this issue for you.

> No matter what the name is, I can `port install assp` or `port  
> install ASSP`, so case is not mattering in the command phase, is  
> this normal?  This is probably an OS X thing being case i?

Yes, this is normal. As far as I know, MacPorts takes care of this on  
all operating systems so it's not Mac OS X-specific.

More information about the macports-users mailing list