installing ghc fails

Inky 788 inky788 at
Wed Jul 1 09:21:23 PDT 2009

On Wed, Jul 1, 2009 at 11:47 AM, Brandon Allbery<allbery at> wrote:
> On Jul 1, 2009, at 11:37 , Inky 788 wrote:
>> On Wed, Jul 1, 2009 at 10:50 AM, Brandon Allbery<allbery at> wrote:
>>> Haddock 2.4.1 isn't compatible with ghc 6.10.2 and later.
>> Perhaps I could install hc-cabal and then use cabal (the Haskell
>> package installer, AFAIK) to get whatever version of Haddock it deems
>> fit.
> That would get you 2.4.2, which should work with 6.10.2/6.10.3, yes.

Ok. I did `sudo port hs-cabal` and it went fine. The `cabal` command
is now in `/opt/local/bin`.

Then I did `cabal update`, and I've got a `~/.cabal` dir. Ran `cabal
install haddock` and got:

~~~ snip ~~~
$ cabal install haddock
Resolving dependencies...
No packages to be installed. All the requested packages are already installed.
If you want to reinstall anyway then use the --reinstall flag.
~~~ /snip ~~~

Weird. (How can I check if it's actually installed? Incidentally, it
is not listed in the output of `port installed`, which is:

The following ports are currently installed:
  ghc @6.10.3_1+darwin_9_i386 (active)
  gmp @4.3.1_0 (active)
  hs-cabal @0.6.2_0 (active)
  hs-ghc-paths @ (active)
  hs-http @4000.0.6_0 (active)
  hs-libcabal @ (active)
  hs-zlib @ (active)
  libedit @20090503-3.0_0 (active)
  ncurses @5.7_0 (active)
  ncursesw @5.7_0 (active)
  perl5.8 @5.8.9_3 (active)
  zlib @1.2.3_2 (active)


Then tried `cabal install pandoc` and it went ahead and installed it.
(!) I tried it out, and it worked. :)

>> Is it ok to use cabal in conjunction with MacPorts when dealing with
>> Haskell packages? Or will that confuse MacPorts?
> My experience is it'll get somewhat confused, as it does when non-MacPorts
> Perl modules are installed. :/

Good to know. Thanks.

More information about the macports-users mailing list