Problem with cairo in ppc - newer xcode required
atma at convalesco.org
Mon Jul 13 07:26:37 PDT 2009
On 13 Ιουλ 2009, at 12:53 ΜΜ, Joshua Root wrote:
> On 2009-7-13 19:42, Panagiotis Atmatzidis wrote:
>> Greetings to the list,
>> I'm trying to install "cacti" but I get the following block:
>> devo:~ atma$ sudo port install cacti
>> ---> Fetching cairo
>> ---> Verifying checksum(s) for cairo
>> ---> Extracting cairo
>> Error: On Mac OS X 10.4, cairo 1.8.8 requires Xcode 2.4.1 or later
>> you have Xcode 2.2.
>> Error: Target org.macports.extract returned: incompatible Xcode
>> Error: The following dependencies failed to build: rrdtool pango
>> Error: Status 1 encountered during processing.
>> My server is a mac mini running on ppc:
>> devo:~ atma$ uname -a
>> Darwin devo.local 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10
>> 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh
>> is there any viable solution here? I think that the 2.4.1 xcode is
>> available for ppc, I remember installing the latest ppc G4 version of
>> xcode when choosing the version.
> I have Xcode 2.5 running fine on a G4.
> - Josh
I really can't find a direct link for xCode 2.5. On MacUpdate I can
see xCode 2.4.1 and then 3.0 not 2.5. On developers connection I was
not able to find a download link. If it's easy for you to give me a
direct link, I already have an apple dev connection account.
Panagiotis (atma) Atmatzidis
email: atma at convalesco.org
GnuPG key id: 0xFC4E8BB4
The wise man said: "Never argue with an idiot. They bring you down to
their level and beat you with experience."
More information about the macports-users