Problem with cairo in ppc - newer xcode required
jmr at macports.org
Mon Jul 13 02:53:11 PDT 2009
On 2009-7-13 19:42, Panagiotis Atmatzidis wrote:
> Greetings to the list,
> I'm trying to install "cacti" but I get the following block:
> devo:~ atma$ sudo port install cacti
> ---> Fetching cairo
> ---> Verifying checksum(s) for cairo
> ---> Extracting cairo
> Error: On Mac OS X 10.4, cairo 1.8.8 requires Xcode 2.4.1 or later but
> you have Xcode 2.2.
> Error: Target org.macports.extract returned: incompatible Xcode version
> Error: The following dependencies failed to build: rrdtool pango cairo
> Error: Status 1 encountered during processing.
> My server is a mac mini running on ppc:
> devo:~ atma$ uname -a
> Darwin devo.local 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10
> 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc
> is there any viable solution here? I think that the 2.4.1 xcode is not
> available for ppc, I remember installing the latest ppc G4 version of
> xcode when choosing the version.
I have Xcode 2.5 running fine on a G4.
More information about the macports-users