Yet Another Problem Installing Amarok

Hal Vaughan hal at
Thu Jun 25 20:03:53 PDT 2009

On Jun 25, 2009, at 8:59 PM, Ryan Schmidt wrote:

> On Jun 25, 2009, at 19:52, Ryan Schmidt wrote:
>> On Jun 25, 2009, at 19:24, Hal Vaughan wrote:
>>> My last problem is cleared now -- it froze on installing kdebase4- 
>>> runtime.  When I got it all working (as in rebooted and updated  
>>> some stuff from Apple), I ran "sudo port install amarok" and it  
>>> went through a lot of stuff, then I'm stuck with this:
>>> --->  Fetching taglib-devel
>>> Error: Target org.macports.fetch returned: Subversion check out  
>>> failed
>>> Error: The following dependencies failed to build: taglib-devel  
>>> taglib-extras
>>> Error: Status 1 encountered during processing.
>>> When I saw that, it sounded like it had a problem reading data  
>>> from an svn repository, so I waited and tried it again, in case a  
>>> site was down.  Still no luck.
>>> So what is actually going on here and how can I fix it?  I tried  
>>> Google, but didn't see much info on it and when I googled the  
>>> error message, I found no hits!
>> taglib-devel wants to check out its files from the KDE project's  
>> anonymous Subversion repository, which seems not to be working for  
>> you. This has been reported before, with no solution listed so far:
>> If you can figure out the solution let us know.
>> What happens if you type
>> svn ls svn://
>> in the terminal? If it's working, it should list the contents of  
>> that directory.

That works and I see the contents of the directory.  And, just in  
case, since I'm using sudo to run Macports, I tried it with sudo and  
it worked as well.  I even logged into a terminal tab as root and  
tried it from there, just to be clear there was no user issue there.

>> I should note that fetching taglib-devel works fine for me, so  
>> maybe there is a problem using the svn protocol (port 3690) on your  
>> network.
> Correction: according to the ticket, the problem is not the initial  
> svn checkout but an external it then wants to check out afterward.  
> The fetch does not fail for me, yet if I use debug mode I see that  
> the external did not get fetched:
> svn: warning: Error handling externals definition for 'taglib/admin':
> svn: warning: OPTIONS of '' 
> : Server certificate verification failed: issuer is not trusted ( 
> )
> I do not know why port did not recognize that this was a fatal error.
> Taking a cue from the above ticket, I ran
> svn ls
> in the terminal and answered "p" to get it to accept the certificate  
> permanently. Then the port fetch worked correctly.

I ran it, both as root and as my user name, again in case there's an  
issue with user rights or anything like that.  Then I ran it again  
under my user account and it asked for the question again.  So I ran  
it another time.  Each time I run it, I pick "p" yet the next time it  
still asks again.

However, I went on and tried to install Amarok again after that and as  
I write this it is configuring taglib.

Ok, I'm lying.  Now it's building taglib.  Anyway, it's working.

It appears like there is a problem with the certificate, since I got  
that message each time I ran the command above.  It wasn't a problem  
with the first command, but is with the 2nd one.

Is it possible you have something else already installed that is  
making use of something similar?

And thanks for the help on this!  I just checked the status and now  
it's building Amarok.  Since that's what I was trying to install in  
the first place, I would expect that to be the last package for it to  


More information about the macports-users mailing list