php 5.9.2 curl 7.19.4 Incompatible library version

harabanar helgih at
Fri May 22 08:17:43 PDT 2009

Hi .. 

I have been trying to upgrade my php5 installation from 5.2.5 to 5.2.9 but
every time I try to restart the apache server or I get the error 

"Reason: Incompatible library version: php requires version 6.0.0 or later,
but libcurl.4.dylib provides version 5.0.0"

Can anyone help me?

Some informations: 
strings /usr/lib/libcurl.4.dylib | grep CLIENT
CLIENT libcurl 7.16.3
CLIENT libcurl 7.16.3
CLIENT libcurl 7.16.3

otool -L /opt/local/apache2/modules/ | grep curl -i
   /opt/local/lib/libcurl.4.dylib (compatibility version 6.0.0, current
version 6.1.0)
View this message in context:
Sent from the MacPorts - Users mailing list archive at

More information about the macports-users mailing list