gnuplot CVS compilation

Joshua Root jmr at
Mon Nov 2 04:01:21 PST 2009

On 2009-11-2 22:08, Wolf Drechsel wrote:
> So I tried compiling gnuplot 4.3 from the CVS again. The gnuplot website
> provides a script which is supposed to do the job:

The script looks reasonable enough, so the problems are probably coming
from gnuplot's build system.

> I tried this script on a Tiger 10.4.11 PPC with macports 1.8.1
> installed, and get the following output messages:

The proximate cause of the failure appears to be:
ld: Undefined symbols:
typeinfo for wxMemoryDC
typeinfo for wxDataObject
typeinfo for wxTopLevelWindowMac
typeinfo for wxApp
typeinfo for wxFrame
typeinfo for wxPanel
typeinfo for wxDialog
typeinfo for wxObject
typeinfo for wxThread
typeinfo for wxControl

However, the preceding warnings about many symbols being taken from
/usr/lib/libwx_macud-2.5.dylib instead of libraries in /opt/local/lib
are highly suspect. Quite possibly what is being warned about
beforehand: "warning suggest use of -bind_at_load, as lazy binding may
result in errors or different symbols being used"

> There comes the line
> /"You need automake newer 1.8 (fink helps)!!"/
> AFAIK macports does only provide automake 1.1 and 1.7 - do I have to bother?

The current automake port is 1.11.

- Josh

More information about the macports-users mailing list