The following dependencies failed to build: libsdl_mixer

Scott Haneda talklists at
Sun Nov 8 18:59:33 PST 2009

Just for *fun* or learning, I tried to install on Intel Leopard. I am  
Error: The following dependencies failed to build: libsdl libsdl_mixer  
libogg libvorbis smpeg

That seems to come from checksum mismatch on one or more of the  
aforementioned dependencies.  Perhaps the upstream made edits to their  
core files, thereby changing the checksums since the portfile was made.

I hate it when they do that, they should rev change the version,  
ALWAYS, even if they change it to 1.1.000000000000001, change the  
version!  Someone needs to contact them and ask them why, to at least  
confirm this is not a real exploit in the code that is causing the  
mismatch.  Checksums are there for a few reasons, one being so that  
malicious can not be shoved in.

Generally, I think you need to take the list of dependencies that  
failed to build, and try each one stand alone, each of which may have  
other dependencies, and each which may have more, you trace the chain  
until you are clean.  Or report it to and  
let the devs work it out.

It looks like the checksum for the below is ok
	$sudo port checksum wxWidgets

	$sudo port deps wxWidgets
Full Name: wxWidgets @2.8.10
Library Dependencies: jpeg, tiff, libpng, zlib, libiconv, expat,  
libsdl, libsdl_mixer

If I check each one:
      $sudo port checksum expat libsdl libsdl_mixer libogg libvorbis  
smpeg jpeg tiff libpng zlib
      --->  Computing dependencies for expat
      --->  Computing dependencies for libsdl
      --->  Verifying checksum(s) for libsdl
      Error: Checksum (md5) mismatch for SDL-1.2.14.tar.gz
      Error: Checksum (sha1) mismatch for SDL-1.2.14.tar.gz
      Error: Checksum (rmd160) mismatch for SDL-1.2.14.tar.gz
      Error: Target org.macports.checksum returned: Unable to verify  
file checksums
      Error: Status 1 encountered during processing.

It looks like there are three errors for checksums:
$sudo port -d checksum libsdl
The correct checksum line may be:
checksums           md5     c2dc23aa9b650e2fd986eb4461c4a839 \
                     sha1    4508b15c77048f36f53eddcccce554bd12e0c322 \
                     rmd160  8333b846f516809f2c442153026e9ede336c45ed

This is sort of a hacky way to do this, and  I will do my best if this  
woks out to submit patches for the portfiles...

$sudo port edit libsdl
Pop in the correct checkums, commented out the old ones.
      $sudo port install libsdl
      Portfile changed since last build; discarding previous state.
      --->  Computing dependencies for libsdl
      --->  Fetching libsdl
      --->  Verifying checksum(s) for libsdl
      --->  Extracting libsdl
      --->  Applying patches to libsdl
      --->  Configuring libsdl
      --->  Building libsdl
      --->  Staging libsdl into destroot
      --->  Installing libsdl @1.2.14_2
      --->  Activating libsdl @1.2.14_2
      --->  Cleaning libsdl

Ok, now, lets remove the work I just did with the installs and see if  
your wxWidgets installs clean.  There are a few I am not going to  
unsintall, as I rely on them for dependencies in apache, gd, php, and  
a few other places.

$sudo port uninstall jpeg tiff libpng zlib libiconv expat libsdl  
*Geesh, this port has a lot of dependencies, still not beating out  
that bastard ASSP. :)

Now, lets try to install
$sudo port -d install wxWidgets
It looks like it worked:

      $port installed | grep wxWidgets
      wxWidgets @2.8.10_0 (active)

I am going to post a patch/diff to trac, and follow up on the dev  
list.  If I stepped though this in a way that is harder than it need  
be, and anyone wants to tell me what is is that I can do to speed this  
process up, I certainly would love to be helped along in that area.
Scott * If you contact me off list replace talklists@ with scott@ *

On Nov 8, 2009, at 1:08 PM, Alex Kac wrote:

> I'm trying to build wxWidgets on SL with MacPorts 1.81. I keep getting
> mismatch errors.
> This topic describes exactly my issue from 2008,
> and I can't see how trying again matter how many times I
> try it doesn't work.

More information about the macports-users mailing list