MySQL Permission Problems

Scott Haneda talklists at
Sat Nov 28 15:15:32 PST 2009

The only thing I can think, is that MySql is not up and running.  Can  
you login to it from the command line directly?  Try `mysql5 -u root`,  
what happens?
Scott * If you contact me off list replace talklists@ with scott@ *

On Nov 28, 2009, at 2:10 PM, Craig Hoffman wrote:

> I'm sort of stumped here.  I just did a clean install of MySQL.
> sudo port install mysql5-server
> After the install I ran this command -
> sudo -u _mysql mysql_install_db5
> It returned the usual messages - Installing tables - ok and so on.   
> No problems reported.   Next, I ran  mysql_secure_installation  
> script.  From the output message:
> "Alternately, you can run:
> sudo /opt/local/lib/mysql5/bin/mysql_secure_installation"
> When I run the script, it returns Error 1045 (28000): Access denied  
> for user 'root at localhost' (Using Password: Yes).  Keep in mind, this  
> is a new install.  I have not setup a root password yet.  Any ideas  
> on whats going on here?  Thanks.

More information about the macports-users mailing list