MySQL Permission Problems

Mark Hattam mark at
Sat Nov 28 15:15:33 PST 2009

On 28 Nov 2009, at 22:10, Craig Hoffman wrote:

> I'm sort of stumped here.  I just did a clean install of MySQL.  
> sudo port install mysql5-server
> After the install I ran this command -
> sudo -u _mysql mysql_install_db5
> It returned the usual messages - Installing tables - ok and so on.  No problems reported.   Next, I ran  mysql_secure_installation script.  From the output message:
> "Alternately, you can run:
> sudo /opt/local/lib/mysql5/bin/mysql_secure_installation" 
> When I run the script, it returns Error 1045 (28000): Access denied for user 'root at localhost' (Using Password: Yes).  Keep in mind, this is a new install.  I have not setup a root password yet.  Any ideas on whats going on here?  Thanks.
> CH
> _______________________
> Craig Hoffman
> iChat / AIM:
> _______________________

You might find Google is your friend ... try  +"Error 1045 (28000)" ... lots of hits, perhaps starting here,34014,34014

Try logging into MySQL without a password ... or set a root password, then run the script ...


More information about the macports-users mailing list