unable to upgrade apache2 on snow leopard

Todd Eddy teddy at sparkbase.com
Tue Sep 15 09:49:38 PDT 2009

Yeah I figured out the problem from before.  The proper way to force  
upgrade and rebuild dependencies in macports 1.8 is

sudo port upgrade --force -R apache2

But after doing that I'm getting an error now with libiconv being  
version 7.0.0 and gawk needs 8.0.0 so I guess I'm still going to  
backup my apache conf, do a port list installed and just start from  

On Sep 15, 2009, at 12:06 PM, Chris Janton wrote:

> On 2009-09-15 , at 08:36 , Todd Eddy wrote:
>> So far most packages have upgraded but apache hasn't worked since I
>> installed snow leopard and still having problems upgrading.  Tried
>> searching for the error and all the suggestions I could find didn't
>> really help.  At the point now where I'm considering installing
>> everything from scratch but hope I can avoid that.
> I thought I had built things from scratch, but hadn't really done
> rm -rf /opt/local/*
> all sorts of problems ensued.
> I installed MacPorts 1.8, completely cleaned out /opt/local (really  
> made the files go away), and re-installed from the beginning.
> It appears to be the only reliable way.
> All my ports are happy now.
> 8)
> ----------------------------------
> Chris Janton  - face at CentosPrime dot COM
> Netminder for Opus1.COM

Privileged/Confidential Information may be contained in this message.

If you are not the addressee indicated in this message (or responsible for delivery of the message to such person), you may not copy or deliver this message to anyone. In such case, you should destroy this message and kindly notify the sender by reply email. Please advise immediately if you or your employer does not consent to Internet email for messages of this kind. Opinions, conclusions and other information in this message that do not relate to the official business of my firm shall be understood as neither given nor endorsed by it.

More information about the macports-users mailing list